<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://nilepost.co.ug/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var jnews_ajax_url = '/?ajax-request=jnews'
</script>
<script type="text/javascript">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</script>

<title>Gen Elly Tumwine is dead! - Nile Post</title>
<meta name="description" content="Nile Post - Gen Elly Tumwine is dead! News" />
<link rel="canonical" href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Gen Elly Tumwine is dead!" />
<meta property="og:description" content="Nile Post - Gen Elly Tumwine is dead! News" />
<meta property="og:url" content="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/" />
<meta property="og:site_name" content="Nile Post" />
<meta property="article:publisher" content="https://www.facebook.com/nilepostnews/" />
<meta property="article:published_time" content="2022-08-25T05:30:54+00:00" />
<meta property="article:modified_time" content="2022-08-25T06:42:42+00:00" />
<meta property="og:image" content="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="698" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Kenneth Kazibwe" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@nilepostnews" />
<meta name="twitter:site" content="@nilepostnews" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Kenneth Kazibwe" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://nilepost.co.ug/#organization","name":"Nile Post","url":"https://nilepost.co.ug/","sameAs":["https://www.facebook.com/nilepostnews/","https://twitter.com/nilepostnews"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/#/schema/logo/image/","url":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","width":600,"height":173,"caption":"Nile Post"},"image":{"@id":"https://nilepost.co.ug/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://nilepost.co.ug/#website","url":"https://nilepost.co.ug/","name":"Nile Post","description":"Accurate news fast","publisher":{"@id":"https://nilepost.co.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://nilepost.co.ug/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#primaryimage","url":"https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg","width":720,"height":698,"caption":"Gen Elly Tumwine."},{"@type":"WebPage","@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/","url":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/","name":"Gen Elly Tumwine is dead! - Nile Post","isPartOf":{"@id":"https://nilepost.co.ug/#website"},"primaryImageOfPage":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#primaryimage"},"image":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#primaryimage"},"thumbnailUrl":"https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg","datePublished":"2022-08-25T05:30:54+00:00","dateModified":"2022-08-25T06:42:42+00:00","description":"Nile Post - Gen Elly Tumwine is dead! News","breadcrumb":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/"]}]},{"@type":"BreadcrumbList","@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://nilepost.co.ug/"},{"@type":"ListItem","position":2,"name":"Blog","item":"https://nilepost.co.ug/blog/"},{"@type":"ListItem","position":3,"name":"Gen Elly Tumwine is dead!"}]},{"@type":"Article","@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#article","isPartOf":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/"},"author":{"name":"Kenneth Kazibwe","@id":"https://nilepost.co.ug/#/schema/person/60e0116bcc8f6eb00410488b2e5257d8"},"headline":"Gen Elly Tumwine is dead!","datePublished":"2022-08-25T05:30:54+00:00","dateModified":"2022-08-25T06:42:42+00:00","mainEntityOfPage":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/"},"wordCount":729,"commentCount":0,"publisher":{"@id":"https://nilepost.co.ug/#organization"},"image":{"@id":"https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#primaryimage"},"thumbnailUrl":"https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg","keywords":["Gen Elly Tumwine","Museveni","NRA","uganda","Ugandan News","UPDF"],"articleSection":["Editor's Choice","Featured","News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#respond"]}]},{"@type":"Person","@id":"https://nilepost.co.ug/#/schema/person/60e0116bcc8f6eb00410488b2e5257d8","name":"Kenneth Kazibwe","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/#/schema/person/image/","url":"https://nilepost.co.ug/wp-content/uploads/2018/06/IMG_8522-2-100x100.jpg","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2018/06/IMG_8522-2-100x100.jpg","caption":"Kenneth Kazibwe"},"sameAs":["http://nilepost.co.ug"],"url":"https://nilepost.co.ug/author/kenny/"}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Feed" href="https://nilepost.co.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Comments Feed" href="https://nilepost.co.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Gen Elly Tumwine is dead! Comments Feed" href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/feed/" />









<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/svrjjdh/7tl1c.css" media="all" />
<link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Roboto%3Aregular%2C500%2C700%2C700%2C500&#038;display=swap&#038;ver=1.2.6' type='text/css' media='all' />





<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/l235xzra/7tl1c.css" media="all" />
<script src='//nilepost.co.ug/wp-content/cache/wpfc-minified/3nbklze/7tl1c.js' type="text/javascript"></script>





<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-142391605-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["nilepost.co.ug"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-142391605-1", {"anonymize_ip":true});
</script>

<link rel="https://api.w.org/" href="https://nilepost.co.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://nilepost.co.ug/wp-json/wp/v2/posts/141634" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nilepost.co.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nilepost.co.ug/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://nilepost.co.ug/?p=141634' />
<link rel="alternate" type="application/json+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.81.0" />

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style>
#wp-admin-bar-pvc-post-views .pvc-graph-container { padding-top: 6px; padding-bottom: 6px; position: relative; display: block; height: 100%; box-sizing: border-box; }
#wp-admin-bar-pvc-post-views .pvc-line-graph {
display: inline-block;
width: 1px;
margin-right: 1px;
background-color: #ccc;
vertical-align: baseline;
}
#wp-admin-bar-pvc-post-views .pvc-line-graph:hover { background-color: #eee; }
#wp-admin-bar-pvc-post-views .pvc-line-graph-0 { height: 1% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-1 { height: 5% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-2 { height: 10% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-3 { height: 15% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-4 { height: 20% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-5 { height: 25% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-6 { height: 30% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-7 { height: 35% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-8 { height: 40% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-9 { height: 45% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-10 { height: 50% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-11 { height: 55% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-12 { height: 60% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-13 { height: 65% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-14 { height: 70% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-15 { height: 75% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-16 { height: 80% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-17 { height: 85% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-18 { height: 90% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-19 { height: 95% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-20 { height: 100% }
</style>

<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5725099935220167" crossorigin="anonymous" type="text/javascript"></script>

<link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy-75x75.png" sizes="32x32" />
<link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" />
<meta name="msapplication-TileImage" content="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">
.no_thumbnail .jeg_thumb,
.thumbnail-container.no_thumbnail {
display: none !important;
}
.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
margin-left: 0;
}
.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
margin-top: 0;
}
.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
position: relative;
}
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
color: #212121 !important;
} 
</style> <style type="text/css" id="wp-custom-css">
.nivo-caption {
background: transparent !important;
position: absolute;
color: transparent !important;
-moz-opacity: .8;
}		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-141634 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jeg_sidecontent jeg_sidecontent_left jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.9.0 vc_responsive">
<div id="jeg_sidecontent">
<div class="jeg_side_heading">
<ul class="jeg_side_tabs">
<li data-tab-content="tab1" data-sort='latest' class="active">Latest</li><li data-tab-content="tab2" data-sort='popular_post' class=""><i class="fa fa-fire"></i> Trending</li> </ul>
<div class="jeg_side_feed_cat_wrapper">
<div class="jeg_cat_dropdown"><button type="button" class="jeg_filter_button">Filter</button>
<ul class="jeg_filter_menu">
<li><a href="#" class='active'>All</a></li>
<li><a class="" href="https://nilepost.co.ug/category/news/" data-id="22">News</a></li><li><a class="" href="https://nilepost.co.ug/category/business/" data-id="106536">Business</a></li><li><a class="" href="https://nilepost.co.ug/category/politics/" data-id="106538">Politics</a></li><li><a class="" href="https://nilepost.co.ug/category/lifestyle/" data-id="106540">Lifestyle</a></li>
</ul></div> </div>
<script> var side_feed = {"paged":1,"post_type":"post","exclude_post":141634,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":"10","number_post":"10","pagination_mode":"loadmore"}; </script> </div>
<div class="sidecontent_postwrapper">
<div class="jeg_sidefeed ">
<div class="jeg_post jeg_pl_md_box active " data-id="141634" data-sequence="0">
<div class="overlay_container">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Gen Elly Tumwine is dead!" loading="lazy" data-full-width="720" data-full-height="698" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9-360x180.jpg" data-srcset="" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/">Gen Elly Tumwine is dead!</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div>
</div><div class="jeg_ad jnews_sidefeed_ads"></div><div class="jeg_post jeg_pl_xs_3  " data-id="141667" data-sequence="1">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Russian rocket hits train in Ukraine killing 22" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="976" data-full-height="549" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/">Russian rocket hits train in Ukraine killing 22</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141653" data-sequence="2">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Bobi Wine: &#8220;I will not be as extravagant as Museveni in State House&#8221;" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1280" data-full-height="852" data-src="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/">Bobi Wine attacks NEMA for &#8220;selectively&#8221; evicting people from wetlands</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141663" data-sequence="3">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Kenya asks Nigeria, Ethiopia to repatriate earnings" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="624" data-full-height="350" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/">Kenya asks Nigeria, Ethiopia to repatriate earnings</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141652" data-sequence="4">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Gen Tumwine died of lung cancer, says Museveni" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="600" data-full-height="400" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/">Gen Tumwine died of lung cancer, says Museveni</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141658" data-sequence="5">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/fresh-fighting-in-ethiopia-shatters-hopes-of-peace/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1023" data-full-height="575" data-src="https://nilepost.co.ug/wp-content/uploads/2021/11/Ethiopian-government-soldiers-ride-in-the-back-of-a-truck-in-the-Tigray-region-of-northern-Ethiopia-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/11/Ethiopian-government-soldiers-ride-in-the-back-of-a-truck-in-the-Tigray-region-of-northern-Ethiopia-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2021/11/Ethiopian-government-soldiers-ride-in-the-back-of-a-truck-in-the-Tigray-region-of-northern-Ethiopia-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/fresh-fighting-in-ethiopia-shatters-hopes-of-peace/">Fresh fighting in Ethiopia shatters hopes of peace</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141654" data-sequence="6">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/ruling-party-takes-early-lead-in-angolan-elections/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Ruling party takes early lead in Angolan elections" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="624" data-full-height="350" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/Vote-counting-is-ongoing-in-the-closely-fought-elections-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/Vote-counting-is-ongoing-in-the-closely-fought-elections-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/08/Vote-counting-is-ongoing-in-the-closely-fought-elections-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/ruling-party-takes-early-lead-in-angolan-elections/">Ruling party takes early lead in Angolan elections</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141641" data-sequence="7">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/kasaija-tumwebaze-pinned-on-distribution-of-coffee-seedlings/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Tayebwa tasks govt to ensure Ugandans in diaspora participate in 2026 elections" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1080" data-full-height="720" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/Tayebwa-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/Tayebwa-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/Tayebwa-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/kasaija-tumwebaze-pinned-on-distribution-of-coffee-seedlings/">Kasaija, Tumwebaze pinned on distribution of coffee seedlings</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141645" data-sequence="8">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/always-stand-by-christian-values-as-you-serve-people-pope-urges-speaker-among/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="&#8220;Always stand by Christian values as you serve people&#8221;- Pope urges Speaker Among" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1080" data-full-height="720" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/5f07690e-433f-4332-9d8d-11af661c1708-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/5f07690e-433f-4332-9d8d-11af661c1708-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/08/5f07690e-433f-4332-9d8d-11af661c1708-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/always-stand-by-christian-values-as-you-serve-people-pope-urges-speaker-among/">&#8220;Always stand by Christian values as you serve people&#8221;- Pope urges Speaker Among</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141642" data-sequence="9">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-tumwine-how-i-fired-first-bullet-to-launch-nra-bush-war/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Tarehe Sita: UPDF generals don new pips for  the first time in Nakaseke" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="2048" data-full-height="1365" data-src="https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-150x150.jpg 150w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/gen-tumwine-how-i-fired-first-bullet-to-launch-nra-bush-war/">Gen Tumwine: How I fired first bullet to launch NRA bush war</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="141632" data-sequence="10">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/08/25/opinion-cosase-probe-on-uganda-airlines-well-intentioned-but-shambolically-executed/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Opinion: Could M23 shoot East African Community into an early political federation?" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="786" data-full-height="589" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/unnamed-75x75.png" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/unnamed-75x75.png 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/unnamed-350x350.png 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/08/25/opinion-cosase-probe-on-uganda-airlines-well-intentioned-but-shambolically-executed/">Opinion: COSASE probe on Uganda Airlines well intentioned but shambolically executed</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div></div>
</div>
</div> </div>
<div class="sidefeed_loadmore">
<button class="btn " data-end="End of Content" data-loading="Loading..." data-loadmore="Load More">
Load More </button>
</div>
</div>
<div class="jeg_sidefeed_overlay">
<div class='preloader_type preloader_dot'>
<div class="sidefeed-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="sidefeed-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="sidefeed-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '><a href='' rel="noopener" class='adlink ads_image '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a><a href='' rel="noopener" class='adlink ads_image_tablet '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a><a href='' rel="noopener" class='adlink ads_image_phone '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header full">
<div class="jeg_midbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://nilepost.co.ug/" style="padding: 0 0 0 0;">
<img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png" srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" alt="Logo" data-light-src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" data-dark-src="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png" data-dark-srcset="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 1x, http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
<div class='ads-wrapper  '></div></div> </div>
</div>
</div>
</div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_nav_icon">
<a href="#" class="toggle_btn jeg_mobile_toggle">
<span></span><span></span><span></span>
</a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-765" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-765 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-130270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130270 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/politics/">Politics</a></li>
<li id="menu-item-115840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115840 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/business/">Business</a></li>
<li id="menu-item-70154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a>
<ul class="sub-menu">
<li id="menu-item-70159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li>
</ul>
</li>
<li id="menu-item-33490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li>
<li id="menu-item-33491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li>
</ul>
</li>
<li id="menu-item-14258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li>
<li id="menu-item-33492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33492 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/security/">Security</a>
<ul class="sub-menu">
<li id="menu-item-130264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130264 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/cyber-security/">Cyber Security</a></li>
</ul>
</li>
<li id="menu-item-115849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115849 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/health-2/">Health</a>
<ul class="sub-menu">
<li id="menu-item-115872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115872 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li>
</ul>
</li>
<li id="menu-item-768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a>
<ul class="sub-menu">
<li id="menu-item-34124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a>
<ul class="sub-menu">
<li id="menu-item-70006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li>
<li id="menu-item-34125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li>
<li id="menu-item-53331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li>
<li id="menu-item-100718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100718 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li>
<li id="menu-item-55490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">But this Year!</a></li>
<li id="menu-item-129114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129114 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/what-did-i-miss/">What Did I Miss?</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-115848" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115848 bgnav" data-item-row="default"><a href="#">Lifestyle</a>
<ul class="sub-menu">
<li id="menu-item-130269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130269 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/hatmahz-kitchen/">Hatmahz Kitchen</a></li>
<li id="menu-item-130268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130268 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/food-hub/">Food Hub</a></li>
<li id="menu-item-130266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130266 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/love-therapist/lets-talk-about-sex/">Let&#8217;s Talk About Sex</a></li>
<li id="menu-item-115861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115861 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/entertainment/">Entertainment</a></li>
<li id="menu-item-115851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115851 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/tour-travel/">Tour &amp; Travel</a></li>
<li id="menu-item-115850" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115850 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/love-therapist/">Love Therapist</a></li>
<li id="menu-item-115857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115857 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/homes/">Homes</a></li>
</ul>
</li>
<li id="menu-item-115843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115843 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/">Global</a>
<ul class="sub-menu">
<li id="menu-item-115832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115832 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li>
<li id="menu-item-115853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115853 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li>
<li id="menu-item-115855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115855 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li>
<li id="menu-item-115854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115854 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li>
<li id="menu-item-115856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115856 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li>
</ul>
</li>
<li id="menu-item-796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a>
<ul class="sub-menu">
<li id="menu-item-798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li>
<li id="menu-item-800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li>
<li id="menu-item-100365" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100365 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/tanzania/">Tanzania</a></li>
<li id="menu-item-799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li>
<li id="menu-item-102325" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102325 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/dr-congo/">DR Congo</a></li>
<li id="menu-item-102326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102326 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/ethiopia/">Ethiopia</a></li>
<li id="menu-item-102327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102327 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/sudan/">Sudan</a></li>
</ul>
</li>
<li id="menu-item-115829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115829 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/technology/">Technology</a></li>
<li id="menu-item-140390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140390 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/ask-the-mechanic/">Ask the Mechanic</a></li>
<li id="menu-item-115830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115830 bgnav" data-item-row="default"><a href="#">Special Reports</a>
<ul class="sub-menu">
<li id="menu-item-115845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115845 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li>
<li id="menu-item-115844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115844 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li>
<li id="menu-item-115846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115846 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li>
<li id="menu-item-115847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115847 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li>
<li id="menu-item-115852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115852 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li>
<li id="menu-item-115863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115863 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li>
<li id="menu-item-115867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115867 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li>
</ul>
</li>
<li id="menu-item-115866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115866 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-115865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115865 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/place-it/">Place-It</a></li>
<li id="menu-item-115868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115868 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li>
<li id="menu-item-115864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115864 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/bundesliga/">Bundesliga</a></li>
<li id="menu-item-115869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115869 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/world-cup/">World Cup</a></li>
</ul>
</li>
<li id="menu-item-115873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115873 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://nilepost.co.ug/">
<img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png" srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" alt="Logo" data-light-src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" data-dark-src="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png" data-dark-srcset="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 1x, http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div>
<div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main ">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article_top jnews_article_top_ads">
<div class='ads-wrapper  '></div> </div>
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id="breadcrumbs"><span class="">
<a href="https://nilepost.co.ug">Home</a>
</span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
<a href="https://nilepost.co.ug/category/editors-choice/">Editor's Choice</a>
</span></div> </div>
<div class="entry-header">
<h1 class="jeg_post_title">Gen Elly Tumwine is dead!</h1>
<h2 class="jeg_post_subtitle">One of the heroes of the 1986 Luweero bush war that brought the current NRM government to power, Gen Elly Tumwine has died at the age of 68.</h2>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">
<div class="meta_left">
<div class="jeg_meta_author">
<img data-del="avatar" alt="Kenneth Kazibwe" src='https://nilepost.co.ug/wp-content/uploads/2018/06/IMG_8522-2-100x100.jpg' class='avatar pp-user-avatar avatar-80 photo ' height='80' width='80' /> <span class="meta_text">by</span>
<a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a> </div>
<div class="jeg_meta_date">
<a href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/">August 25, 2022</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://nilepost.co.ug/category/editors-choice/" rel="category tag">Editor's Choice</a><span class="category-separator">, </span><a href="https://nilepost.co.ug/category/news/featured/" rel="category tag">Featured</a><span class="category-separator">, </span><a href="https://nilepost.co.ug/category/news/" rel="category tag">News</a> </span>
</div>
<div class="jeg_meta_reading_time">
<span>
Reading Time: 3 mins read
</span>
</div> </div>
<div class="meta_right">
<div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/#comments"><i class="fa fa-comment-o"></i> 0</a></div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="jeg_main_content col-md-8">
<div class="jeg_inner_content">
<div class="jeg_featured featured_image"><a href="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:96.944%"><img width="720" height="698" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-featured-750 size-jnews-featured-750 lazyload wp-post-image" alt="Gen Elly Tumwine is dead!" loading="lazy" data-full-width="720" data-full-height="698" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9.jpg" data-srcset="" data-sizes="auto" data-expand="700" /></div><p class="wp-caption-text">Gen Elly Tumwine.</p></a></div>
<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
<div class="jeg_share_stats">
</div>
<div class="jeg_sharelist">
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' class="jeg_btn-facebook "><i class="fa fa-facebook-official"></i></a><a href="https://twitter.com/intent/tweet?text=Gen%20Elly%20Tumwine%20is%20dead%21&url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' class="jeg_btn-twitter "><i class="fa fa-twitter"></i></a><a href="//api.whatsapp.com/send?text=Gen%20Elly%20Tumwine%20is%20dead%21%0Ahttps%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' data-action="share/whatsapp/share" class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
<div class="entry-content no-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
<div class="jeg_share_float_container"></div> </div>
<div class="content-inner ">
<p><strong>One of the heroes of the 1986 Luweero bush war that brought the current NRM government to power, Gen Elly Tumwine has died at the age of 68.</strong></p>
<p>Tumwine died from Aga Khan Hospital in Nairobi, Kenya, where he was airlifted recently as he battled cancer -related complications.</p>
<p>However, details are still scanty about the matter.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_3_ads  "><div class='ads-wrapper align-center '><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image_tablet align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image_phone align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><div class='ads-text'>ADVERTISEMENT</div></div></div>
<p>Tumwine is one of the 42 people armed with 27 guns who attacked Kabamba barracks to launch the NRA protracted war that five years later in 1986 would usher the current government to power.</p>
<p>Having left his teaching career in 1978, Tumwine joined the FRONASA forces led by Museveni.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads  "><div class='ads-wrapper align-center '><div class='ads_code'><ins class='dcmads' style='display:inline-block;width:300px;height:250px' data-dcm-placement='N1480557.3185639NILEPOST/B25500986.332636749' data-dcm-rendering-mode='iframe' data-dcm-https-only data-dcm-gdpr-applies='gdpr=${GDPR}' data-dcm-gdpr-consent='gdpr_consent=${GDPR_CONSENT_755}' data-dcm-addtl-consent='addtl_consent=${ADDTL_CONSENT}' data-dcm-ltd='false' data-dcm-resettable-device-id='' data-dcm-app-id=''> <script src='https://www.googletagservices.com/dcm/dcmads.js'></script> </ins></div><div class='ads-text'>ADVERTISEMENT</div></div></div>
<p>In 1981, when then rebel leader Yoweri Museveni went to the bush to form the National Resistance Army (NRA) after disputing the outcome of the 1980 elections, Tumwine went with him.</p>
<p>“We had earlier got in touch and discussed with Museveni who had taught me in primary school that if the 1980 elections were rigged, we could go to the bush as the only way out,”Tumwine told the Nile Post in an interview in 2018.</p>
<p>Tumwine is credited for having fired the first bullet that lunched the five year war of the National Resistance Army.</p>
<p>He has spoken elaborately about firing the first bullet during the operation that launched the Luweero bush war.</p>
<p>By January 1986, he was one of the six original members of the NRA High Command which later metamorphosed into the current UPDF High Command.</p>
<p><strong>Loved and hated in equal measure</strong></p>
<p>Whereas he is loved by many, Tumwine has also made remarks in the public that led many to hate him .</p>
<p>For example in 2020, while still the Security Minister, Gen Tumwine rattled the public  when he said the state has powers to shoot to kill protesters.</p>
<p>Speaking in regards the November 14 riots after the arrest of NUP presidential candidate Robert Kyagulanyi, also known as Bobi Wine, Tumwine told journalists said that he had no apologies for anybody who was killed while attacking security forces as they tried to put down protests.</p>
<p>Tumwine said that government will not look on as political actors supported by unnamed foreign forces are disrupting the peace. He said that although they commiserate with families that lost loved ones in the two days of running battles between the security forces and supporters of National Unity Platform, Robert Kyagulanyi, violence normally leads to deaths and destruction.</p>
<p>The statement didn’t augur well with members of the public, many of whom attacked him.</p>
<p>“It is unfortunate when you hear a top government official saying police can shoot and kill. It is not founded under any law. The duty of police is to protect, safeguard and guarantee order, not to kill the very civilians they are mandated to protect,” Fredrick Ssemwanga, the Secretary General of the Uganda Catholic Lawyers’ Society said in response to Tumwine’s remarks.</p>
<p>With many accusing him of holding a sense of entitlement, Tumwine has on several occasions clashed with politicians, especially from the opposition but on other occasions, he has responded to them through his songs.</p>
<p>He has always made his role in liberating Uganda known by everyone and on several occasions, whenever he was attacked, he would remind the public of this.</p>
<p>Tumwine clashed with parliament in 2018 when was ordered to vacate the Nommo Gallery in Nakasero that he had occupied and put his art pieces but never paid rent said to have accumulated up to shs1 billion.</p>
<p>However, despite being ordered to vacate, Gen Tumwine didn’t heed to the directive.</p>
<p><strong>Military background</strong></p>
<p>Joining the army in 1978 , Tumwine later joined then rebel leader Yoweri Museveni to the bush to form the National Resistance Army (NRA).</p>
<p>In 1984, he was named commander of the army, a post he held for three years until 1987, when he was succeeded by General Salim Saleh.</p>
<p>In September 2005, he was promoted to the rank of general in the UPDF and chairperson of the UPDF General Court Martial in Makindye where among the persons arraigned before him was opposition strongman, Dr.Kizza Besigye and charged with treason.</p>
<p>The case was later transferred to the civilian court.</p>
<p>During his career, Gen Tumwine also served as Minister of State for Defence in 1989, Director General of the External Security Organization (ESO) from 1994 until 1996, presidential adviser  on security from 1996 until 1998, chairman of the High Command Appeals Committee from 1986 until 1999.</p>
<p>Tumwine has also previously represented the UPDF in the Parliament.</p>
<p>&nbsp;</p>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://nilepost.co.ug/tag/gen-elly-tumwine/" rel="tag">Gen Elly Tumwine</a><a href="https://nilepost.co.ug/tag/museveni/" rel="tag">Museveni</a><a href="https://nilepost.co.ug/tag/nra/" rel="tag">NRA</a><a href="https://nilepost.co.ug/tag/uganda/" rel="tag">uganda</a><a href="https://nilepost.co.ug/tag/ugandan-news/" rel="tag">Ugandan News</a><a href="https://nilepost.co.ug/tag/updf/" rel="tag">UPDF</a></div>
</div>
</div>
<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
<div class="jeg_sharelist">
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=Gen%20Elly%20Tumwine%20is%20dead%21&url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a><a href="//api.whatsapp.com/send?text=Gen%20Elly%20Tumwine%20is%20dead%21%0Ahttps%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" rel='nofollow' class="jeg_btn-whatsapp expanded"><i class="fa fa-whatsapp"></i><span>Send</span></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
<a href="https://nilepost.co.ug/2022/08/25/opinion-cosase-probe-on-uganda-airlines-well-intentioned-but-shambolically-executed/" class="post prev-post">
<span class="caption">Previous Post</span>
<h3 class="post-title">Opinion: COSASE probe on Uganda Airlines well intentioned but shambolically executed</h3>
</a>
<a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-how-i-fired-first-bullet-to-launch-nra-bush-war/" class="post next-post">
<span class="caption">Next Post</span>
<h3 class="post-title">Gen Tumwine: How I fired first bullet to launch NRA bush war</h3>
</a>
</div></div><div class="jnews_author_box_container ">
<div class="jeg_authorbox">
<div class="jeg_author_image">
<img data-del="avatar" alt="Kenneth Kazibwe" src='https://nilepost.co.ug/wp-content/uploads/2018/06/IMG_8522-2-100x100.jpg' class='avatar pp-user-avatar avatar-80 photo ' height='80' width='80' /> </div>
<div class="jeg_author_content">
<h3 class="jeg_author_name">
<a href="https://nilepost.co.ug/author/kenny/">
Kenneth Kazibwe </a>
</h3>
<p class="jeg_author_desc">
</p>
<div class="jeg_author_socials">
<a target='_blank' href='http://nilepost.co.ug' class='url'><i class='fa fa-globe'></i> </a>
</div>
</div>
</div>
</div><div class="jnews_related_post_container"><div class="jeg_postblock_3 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_141634_0_63072a2abb06c   " data-unique="jnews_module_141634_0_63072a2abb06c">
<div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
</div>
<div class="jeg_posts jeg_block_container">
<div class="jeg_posts jeg_load_more_flag">
<article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Russian rocket hits train in Ukraine killing 22" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="976" data-full-height="549" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-350x250.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-750x536.jpeg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/">Russian rocket hits train in Ukraine killing 22</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/admin/">NP admin</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/"><i class="fa fa-clock-o"></i> August 25, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>A Russian rocket strike on a Ukrainian train station has killed 22 people, Ukraine says, on the day marking six...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Bobi Wine: &#8220;I will not be as extravagant as Museveni in State House&#8221;" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="1280" data-full-height="852" data-src="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-350x250.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-750x536.jpeg 750w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-1140x815.jpeg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/">Bobi Wine attacks NEMA for &#8220;selectively&#8221; evicting people from wetlands</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/muhamad/">Muhamadi Matovu</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/"><i class="fa fa-clock-o"></i> August 25, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>The leader of the National Unity Platform Robert Kyagulanyi alias Bobi Wine has lashed out at the government and law...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Kenya asks Nigeria, Ethiopia to repatriate earnings" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="624" data-full-height="350" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-350x250.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-120x86.jpeg 120w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/">Kenya asks Nigeria, Ethiopia to repatriate earnings</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/admin/">NP admin</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/"><i class="fa fa-clock-o"></i> August 25, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>The Kenyan authorities are in talks with their Nigerian and Ethiopian counterparts to repatriate tens of millions of dollars belonging...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Gen Tumwine died of lung cancer, says Museveni" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="600" data-full-height="400" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-350x250.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/08/pp03pix-data-120x86.jpg 120w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/">Gen Tumwine died of lung cancer, says Museveni</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/"><i class="fa fa-clock-o"></i> August 25, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-died-of-lung-cancer-says-museveni/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>President Museveni has said  former Security Minister and NRA bush war hero, Gen Elly Tumwine died of lung cancer. “With...</p>
</div>
</div>
</article>
</div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_141634_0_63072a2abb06c = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"4","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":141634,"include_category":"107460,95,22,58295,69121,4107,87,95,16,3477","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","job_listing_type":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":3,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_3"};</script>
</div></div><div class="jnews_popup_post_container"> <section class="jeg_popup_post">
<span class="caption">Next Post</span>
<div class="jeg_popup_content">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-how-i-fired-first-bullet-to-launch-nra-bush-war/">
<div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Tarehe Sita: UPDF generals don new pips for  the first time in Nakaseke" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="2048" data-full-height="1365" data-src="https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2020/02/84728558_1827508054051277_6663752780353634304_o-150x150.jpg 150w" data-sizes="auto" data-expand="700" /></div> </a>
</div>
<h3 class="post-title">
<a href="https://nilepost.co.ug/2022/08/25/gen-tumwine-how-i-fired-first-bullet-to-launch-nra-bush-war/">
Gen Tumwine: How I fired first bullet to launch NRA bush war </a>
</h3>
</div>
<a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
</section>
</div><div class="jnews_comment_container"> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/08/25/gen-elly-tumwine-is-dead/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://nilepost.co.ug/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<div class="gglcptch gglcptch_v2"><div id="gglcptch_recaptcha_1663341861" class="gglcptch_recaptcha"></div>
<noscript>
<div style="width: 302px;">
<div style="width: 302px; height: 422px; position: relative;">
<div style="width: 302px; height: 422px; position: absolute;">
<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcyQYYcAAAAAI7vvUVrJ_ZK7Oo7YMTjSbd0FAmg" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
</div>
</div>
<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
</div>
</div>
</noscript></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='141634' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div> </div>
</div>
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
<div class="widget widget_jnews_tab_post" id="jnews_tab_post-21"><div class="jeg_tabpost_widget"><ul class="jeg_tabpost_nav">
<li data-tab-content="jeg_tabpost_1" class="active">Trending</li>
<li data-tab-content="jeg_tabpost_2">Comments</li>
<li data-tab-content="jeg_tabpost_3">Latest</li>
</ul><div class="jeg_tabpost_content"><div class="jeg_tabpost_item active" id="jeg_tabpost_1"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Gen Elly Tumwine is dead!" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="720" data-full-height="698" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/08/93ed09d8-ddbb-4e41-a99c-74f0d4fe41e9-350x250.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/25/gen-elly-tumwine-is-dead/">Gen Elly Tumwine is dead!</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 25, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/24/former-uganda-airlines-ceo-muleya-pins-bamuturaki-of-flouting-airline-guidelines/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Uganda Airlines will be serious player, to fly to nine cities in Africa – Officials" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="4512" data-full-height="3008" data-src="https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/24/former-uganda-airlines-ceo-muleya-pins-bamuturaki-of-flouting-airline-guidelines/">Former Uganda Airlines CEO Muleya pins Bamuturaki of flouting Airline guidelines</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 24, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/21/stanbic-bank-ceo-anne-juuko-introduces-husband/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Stanbic Bank CEO Anne Juuko introduces husband" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="2088" data-full-height="1392" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/juuko-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/juuko-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/08/juuko-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/08/juuko-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2022/08/juuko-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/21/stanbic-bank-ceo-anne-juuko-introduces-husband/">Stanbic Bank CEO Anne Juuko introduces husband</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> August 21, 2022</div>
</div>
</div>
</div></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_2"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/19/spare-the-rod-and-spoil-the-child-the-dilemma-of-todays-so-called-corporate-parents/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Why do we fail to spend harmonious Christmas holidays with the very people we grew up with? " loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="625" data-full-height="410" data-src="https://nilepost.co.ug/wp-content/uploads/2021/09/A-parent-talking-down-to-a-child-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/A-parent-talking-down-to-a-child-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/09/A-parent-talking-down-to-a-child-350x250.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/19/spare-the-rod-and-spoil-the-child-the-dilemma-of-todays-so-called-corporate-parents/">&#8216;Spare the rod and spoil the child&#8217;: the dilemma of today&#8217;s so called corporate parents</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 3</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/21/negative-comments-on-uganda-airline-ceo-on-social-media-will-kill-our-national-asset-minister/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Uganda Airlines will be serious player, to fly to nine cities in Africa – Officials" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="4512" data-full-height="3008" data-src="https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2019/05/NIC_2325-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/21/negative-comments-on-uganda-airline-ceo-on-social-media-will-kill-our-national-asset-minister/">Negative comments on Uganda Airline CEO on social media will kill our national asset- Minister</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-comment-o"></i> 1</div>
</div>
</div>
</div></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_3"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Russian rocket hits train in Ukraine killing 22" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="976" data-full-height="549" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-120x86.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/08/A-residential-house-was-also-destroyed-in-strikes-on-Chaplyne-750x536.jpeg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/25/russian-rocket-hits-train-in-ukraine-killing-22/">Russian rocket hits train in Ukraine killing 22</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> August 25, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Bobi Wine: &#8220;I will not be as extravagant as Museveni in State House&#8221;" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1280" data-full-height="852" data-src="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-120x86.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-750x536.jpeg 750w, https://nilepost.co.ug/wp-content/uploads/2022/06/Bobi-Wine-1140x815.jpeg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/25/bobi-wine-attacks-nema-for-selectively-evicting-people-from-wetlands/">Bobi Wine attacks NEMA for &#8220;selectively&#8221; evicting people from wetlands</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> August 25, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Kenya asks Nigeria, Ethiopia to repatriate earnings" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="624" data-full-height="350" data-src="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-120x86.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/08/Kenya-Airways-is-citing-loses-caused-by-withholding-of-earnings-350x250.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/08/25/kenya-asks-nigeria-ethiopia-to-repatriate-earnings/">Kenya asks Nigeria, Ethiopia to repatriate earnings</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> August 25, 2022</div>
</div>
</div>
</div></div></div></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-35"><div class='jeg_ad jeg_ad_module jnews_module_141634_1_63072a2b3aba9   '><div class='ads-wrapper'></div></div></div></div> </div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper  '><div class="ads_google_ads">
<style type='text/css' scoped>
.adsslot_uWLUZ9JGq2{ width:970px !important; height:90px !important; }
@media (max-width:1199px) { .adsslot_uWLUZ9JGq2{ width:468px !important; height:60px !important; } }
@media (max-width:767px) { .adsslot_uWLUZ9JGq2{ width:320px !important; height:50px !important; } }
</style>
<ins class="adsbygoogle adsslot_uWLUZ9JGq2" style="display:inline-block;" data-ad-client="ca-pub-9432907822779049" data-ad-slot="1638020039"></ins>
<script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-141634 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jeg_sidecontent jeg_sidecontent_left jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.9.0 vc_responsive"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_4 normal">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-9 footer_column">
<ul class="jeg_menu_footer"><li id="menu-item-119307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119307"><a href="#">About</a></li>
<li id="menu-item-119308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119308"><a href="#">Advertise</a></li>
<li id="menu-item-119309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119309"><a href="#">Privacy &#038; Policy</a></li>
<li id="menu-item-119310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119310"><a href="https://nilepost.co.ug/jobs/">Careers</a></li>
</ul> </div>
<div class="col-md-3 footer_column footer_right">
<div class="footer-text">
<strong> Call us: +256-417-720-101</strong><br>
<strong> Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5b3e3f322f3429323a371b3532373e2b34282f753834752e3c">[email&#160;protected]</a> </div>
</div>
</div>
<div class="jeg_footer_secondary clearfix">
<div class="col-md-9 footer_column">
<p class="copyright"> © 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company. </p>
</div>
<div class="col-md-3 footer_column footer_right">
<div class="jeg_social_icon_block socials_widget nobg">
<a href="https://www.facebook.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
</div>

<div id="jeg_off_canvas" class="normal">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-765"><a href="https://nilepost.co.ug/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130270"><a href="https://nilepost.co.ug/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115840"><a href="https://nilepost.co.ug/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33492"><a href="https://nilepost.co.ug/category/news/security/">Security</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130264"><a href="https://nilepost.co.ug/category/cyber-security/">Cyber Security</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115849"><a href="https://nilepost.co.ug/category/health-2/">Health</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115872"><a href="https://nilepost.co.ug/category/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100718"><a href="https://nilepost.co.ug/category/opinions/columns/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">But this Year!</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129114"><a href="https://nilepost.co.ug/category/what-did-i-miss/">What Did I Miss?</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115848"><a href="#">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130269"><a href="https://nilepost.co.ug/category/hatmahz-kitchen/">Hatmahz Kitchen</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130268"><a href="https://nilepost.co.ug/category/food-hub/">Food Hub</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130266"><a href="https://nilepost.co.ug/category/love-therapist/lets-talk-about-sex/">Let&#8217;s Talk About Sex</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115861"><a href="https://nilepost.co.ug/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115851"><a href="https://nilepost.co.ug/category/tour-travel/">Tour &amp; Travel</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115850"><a href="https://nilepost.co.ug/category/love-therapist/">Love Therapist</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115857"><a href="https://nilepost.co.ug/category/homes/">Homes</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115843"><a href="https://nilepost.co.ug/category/global-watch/">Global</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115832"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115853"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115855"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115854"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115856"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100365"><a href="https://nilepost.co.ug/category/east-africa/tanzania/">Tanzania</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102325"><a href="https://nilepost.co.ug/category/east-africa/dr-congo/">DR Congo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102326"><a href="https://nilepost.co.ug/category/east-africa/ethiopia/">Ethiopia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102327"><a href="https://nilepost.co.ug/category/east-africa/sudan/">Sudan</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115829"><a href="https://nilepost.co.ug/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140390"><a href="https://nilepost.co.ug/category/ask-the-mechanic/">Ask the Mechanic</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115830"><a href="#">Special Reports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115845"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115844"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115846"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115847"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115852"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115863"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115867"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115866"><a href="https://nilepost.co.ug/category/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115865"><a href="https://nilepost.co.ug/category/place-it/">Place-It</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115868"><a href="https://nilepost.co.ug/category/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115864"><a href="https://nilepost.co.ug/category/bundesliga/">Bundesliga</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115869"><a href="https://nilepost.co.ug/category/world-cup/">World Cup</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115873"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item socials_widget circle">
<a href="https://www.facebook.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
<p>© 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company.</p>
</div> </div>
</div> </div>
</div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var jfla = ["view_counter"]</script><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
<div class="pswp__bg"></div>
<div class="pswp__scroll-wrap">
<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>
<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">
<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div><div id="selectShareContainer">
<div class="selectShare-inner">
<div class="select_share jeg_share_button">
<button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" data-image-url="" data-title="Gen%20Elly%20Tumwine%20is%20dead%21"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fnilepost.co.ug%2F2022%2F08%2F25%2Fgen-elly-tumwine-is-dead%2F" data-image-url="" data-title="Gen%20Elly%20Tumwine%20is%20dead%21"><i class="fa fa-twitter"></i></a>
</div>
<div class="selectShare-arrowClip">
<div class="selectShare-arrow"></div>
</div>
</div>
</div><div class="jeg_read_progress_wrapper"></div>
<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/2frvua3x/7tl5c.css" media="all" />
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"e7d13ccf8e","disable_ajax_form":"false","is_checkout":"0","is_checkout_tax_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=4.1.1' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/photoswipe/photoswipe.js?ver=10.0.3' id='photoswipe-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/photoswipe/photoswipe-ui-default.js?ver=10.0.3' id='photoswipe-ui-default-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/nilepost.co.ug\/2022\/08\/25\/gen-elly-tumwine-is-dead","popup_script":"photoswipe","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"141634","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"nilepost.co.ug","zoom_button":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=10.0.3' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.0.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit&#038;ver=1.67' id='gglcptch_api-js'></script>
<script type='text/javascript' id='gglcptch_script-js-extra'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"v2","sitekey":"6LcyQYYcAAAAAI7vvUVrJ_ZK7Oo7YMTjSbd0FAmg","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":1,"theme":"light"},"vars":{"visibility":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/google-captcha/js/script.js?ver=1.67' id='gglcptch_script-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(e.data.counter,(function(e,n){o[n].length&&t.forEach(o[n],(function(n,o){t.setText(n,e)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script><script>(function(){var js = "window['__CF$cv$params']={r:'7402c9aa5e1d3823',m:'4nstDa1Y0iD_zTBNLUKQWxTgNtZqtZnGpYVgHV7v3uE-1661414361-0-AYmoif+bO+vb5MqsLL5HfLuw42cYPpizIuZNmy49gghVGRn3JQLEDBoeIWkxK2FrwXVUa95LEnkNCkf8pjoy951nVjx/zm7nlCji0dFj8Ix9MkHrE7b8lDckiLFcYisTt36oTiz+fmKeruC4Iljo42CDfojInfd0sj3tUmjT+KLE',s:[0x1e4ef58058,0x9a6d388f85],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>