<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://nilepost.co.ug/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var jnews_ajax_url = '/?ajax-request=jnews'
</script>
<script type="text/javascript">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</script>

<title>MTN, YoTV unveil redesigned YoTV app with more entertainment channels - Nile Post</title>
<meta name="description" content="Nile Post - MTN, YoTV unveil redesigned YoTV app with more entertainment channels Entertainment" />
<link rel="canonical" href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="MTN, YoTV unveil redesigned YoTV app with more entertainment channels" />
<meta property="og:description" content="Nile Post - MTN, YoTV unveil redesigned YoTV app with more entertainment channels Entertainment" />
<meta property="og:url" content="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/" />
<meta property="og:site_name" content="Nile Post" />
<meta property="article:publisher" content="https://www.facebook.com/nilepostnews/" />
<meta property="article:published_time" content="2022-07-31T06:30:25+00:00" />
<meta property="article:modified_time" content="2022-07-30T10:09:19+00:00" />
<meta property="og:image" content="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="684" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Amon Katungulu" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@nilepostnews" />
<meta name="twitter:site" content="@nilepostnews" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Amon Katungulu" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://nilepost.co.ug/#organization","name":"Nile Post","url":"https://nilepost.co.ug/","sameAs":["https://www.facebook.com/nilepostnews/","https://twitter.com/nilepostnews"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/#/schema/logo/image/","url":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","width":600,"height":173,"caption":"Nile Post"},"image":{"@id":"https://nilepost.co.ug/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://nilepost.co.ug/#website","url":"https://nilepost.co.ug/","name":"Nile Post","description":"Accurate news fast","publisher":{"@id":"https://nilepost.co.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://nilepost.co.ug/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#primaryimage","url":"https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg","width":1024,"height":684,"caption":"Susan Kayemba"},{"@type":"WebPage","@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/","url":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/","name":"MTN, YoTV unveil redesigned YoTV app with more entertainment channels - Nile Post","isPartOf":{"@id":"https://nilepost.co.ug/#website"},"primaryImageOfPage":{"@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#primaryimage"},"datePublished":"2022-07-31T06:30:25+00:00","dateModified":"2022-07-30T10:09:19+00:00","description":"Nile Post - MTN, YoTV unveil redesigned YoTV app with more entertainment channels Entertainment","breadcrumb":{"@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/"]}]},{"@type":"BreadcrumbList","@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://nilepost.co.ug/"},{"@type":"ListItem","position":2,"name":"Blog","item":"https://nilepost.co.ug/blog/"},{"@type":"ListItem","position":3,"name":"MTN, YoTV unveil redesigned YoTV app with more entertainment channels"}]},{"@type":"Article","@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#article","isPartOf":{"@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/"},"author":{"name":"Amon Katungulu","@id":"https://nilepost.co.ug/#/schema/person/c1a38bba3e2652793e56fd8c87b005a9"},"headline":"MTN, YoTV unveil redesigned YoTV app with more entertainment channels","datePublished":"2022-07-31T06:30:25+00:00","dateModified":"2022-07-30T10:09:19+00:00","mainEntityOfPage":{"@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/"},"wordCount":437,"commentCount":0,"publisher":{"@id":"https://nilepost.co.ug/#organization"},"image":{"@id":"https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#primaryimage"},"thumbnailUrl":"https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg","keywords":["MTN","susan kayemba","yotv"],"articleSection":["Entertainment"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#respond"]}]},{"@type":"Person","@id":"https://nilepost.co.ug/#/schema/person/c1a38bba3e2652793e56fd8c87b005a9","name":"Amon Katungulu","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://nilepost.co.ug/#/schema/person/image/","url":"https://nilepost.co.ug/wp-content/uploads/2017/10/np.jpg","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2017/10/np.jpg","caption":"Amon Katungulu"},"sameAs":["http://www.nilepost.co.ug","https://twitter.com/@nilepostnews"],"url":"https://nilepost.co.ug/author/nilepost/"}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Feed" href="https://nilepost.co.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Comments Feed" href="https://nilepost.co.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; MTN, YoTV unveil redesigned YoTV app with more entertainment channels Comments Feed" href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/feed/" />









<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/svrjjdh/7tl1c.css" media="all" />
<link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Roboto%3Aregular%2C500%2C700%2C700%2C500&#038;display=swap&#038;ver=1.2.6' type='text/css' media='all' />





<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/l235xzra/7tl1c.css" media="all" />
<script src='//nilepost.co.ug/wp-content/cache/wpfc-minified/3nbklze/7tl1c.js' type="text/javascript"></script>





<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-142391605-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["nilepost.co.ug"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-142391605-1", {"anonymize_ip":true});
</script>

<link rel="https://api.w.org/" href="https://nilepost.co.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://nilepost.co.ug/wp-json/wp/v2/posts/139734" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nilepost.co.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nilepost.co.ug/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://nilepost.co.ug/?p=139734' />
<link rel="alternate" type="application/json+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.79.0" />

<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<style>
#wp-admin-bar-pvc-post-views .pvc-graph-container { padding-top: 6px; padding-bottom: 6px; position: relative; display: block; height: 100%; box-sizing: border-box; }
#wp-admin-bar-pvc-post-views .pvc-line-graph {
display: inline-block;
width: 1px;
margin-right: 1px;
background-color: #ccc;
vertical-align: baseline;
}
#wp-admin-bar-pvc-post-views .pvc-line-graph:hover { background-color: #eee; }
#wp-admin-bar-pvc-post-views .pvc-line-graph-0 { height: 1% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-1 { height: 5% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-2 { height: 10% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-3 { height: 15% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-4 { height: 20% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-5 { height: 25% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-6 { height: 30% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-7 { height: 35% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-8 { height: 40% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-9 { height: 45% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-10 { height: 50% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-11 { height: 55% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-12 { height: 60% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-13 { height: 65% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-14 { height: 70% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-15 { height: 75% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-16 { height: 80% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-17 { height: 85% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-18 { height: 90% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-19 { height: 95% }
#wp-admin-bar-pvc-post-views .pvc-line-graph-20 { height: 100% }
</style>

<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5725099935220167" crossorigin="anonymous" type="text/javascript"></script>

<link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy-75x75.png" sizes="32x32" />
<link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" />
<meta name="msapplication-TileImage" content="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">
.no_thumbnail .jeg_thumb,
.thumbnail-container.no_thumbnail {
display: none !important;
}
.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
margin-left: 0;
}
.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
margin-top: 0;
}
.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
position: relative;
}
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
color: #212121 !important;
} 
</style> <style type="text/css" id="wp-custom-css">
.nivo-caption {
background: transparent !important;
position: absolute;
color: transparent !important;
-moz-opacity: .8;
}		</style>
<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-139734 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jeg_sidecontent jeg_sidecontent_left jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.9.0 vc_responsive">
<div id="jeg_sidecontent">
<div class="jeg_side_heading">
<ul class="jeg_side_tabs">
<li data-tab-content="tab1" data-sort='latest' class="active">Latest</li><li data-tab-content="tab2" data-sort='popular_post' class=""><i class="fa fa-fire"></i> Trending</li> </ul>
<div class="jeg_side_feed_cat_wrapper">
<div class="jeg_cat_dropdown"><button type="button" class="jeg_filter_button">Filter</button>
<ul class="jeg_filter_menu">
<li><a href="#" class='active'>All</a></li>
<li><a class="" href="https://nilepost.co.ug/category/news/" data-id="22">News</a></li><li><a class="" href="https://nilepost.co.ug/category/business/" data-id="106536">Business</a></li><li><a class="" href="https://nilepost.co.ug/category/politics/" data-id="106538">Politics</a></li><li><a class="" href="https://nilepost.co.ug/category/lifestyle/" data-id="106540">Lifestyle</a></li>
</ul></div> </div>
<script> var side_feed = {"paged":1,"post_type":"post","exclude_post":139734,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":"10","number_post":"10","pagination_mode":"loadmore"}; </script> </div>
<div class="sidecontent_postwrapper">
<div class="jeg_sidefeed ">
<div class="jeg_post jeg_pl_md_box active " data-id="139734" data-sequence="0">
<div class="overlay_container">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="MTN, YoTV unveil redesigned YoTV app with more entertainment channels" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-full-width="1024" data-full-height="684" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-360x180.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-360x180.jpg 360w, https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-750x375.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/">MTN, YoTV unveil redesigned YoTV app with more entertainment channels</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div>
</div><div class="jeg_ad jnews_sidefeed_ads"></div><div class="jeg_post jeg_pl_xs_3  " data-id="139789" data-sequence="1">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/10-dead-scores-missing-as-floods-hit-eastern-uganda/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="10 dead, scores missing as floods hit eastern Uganda" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="645" data-full-height="1165" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/10-dead-scores-missing-as-floods-hit-eastern-uganda/">10 dead, scores missing as floods hit eastern Uganda</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139784" data-sequence="2">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Girl power, umbrellas and Cider dominate Tiwa Savage concert" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="936" data-full-height="620" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/">Girl power, umbrellas and Cider dominate Tiwa Savage concert</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139779" data-sequence="3">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/eddie-kwizera-chosen-as-nrm-party-flag-bearer-but-challenger-cries-foul/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Eddie Kwizera chosen as NRM party flag bearer but challenger cries foul " loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1080" data-full-height="720" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-75x75.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-75x75.jpeg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-350x350.jpeg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/eddie-kwizera-chosen-as-nrm-party-flag-bearer-but-challenger-cries-foul/">Eddie Kwizera chosen as NRM party flag bearer but challenger cries foul </a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139769" data-sequence="4">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/marriage-can-be-a-goldmine-or-a-landmine-couples-warned/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Marriage can be a goldmine or a landmine, couples warned" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1080" data-full-height="718" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/d20f0538-3927-418e-a7e3-6cfdb2d9897b-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/d20f0538-3927-418e-a7e3-6cfdb2d9897b-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/d20f0538-3927-418e-a7e3-6cfdb2d9897b-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/marriage-can-be-a-goldmine-or-a-landmine-couples-warned/">Marriage can be a goldmine or a landmine, couples warned</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139765" data-sequence="5">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/glitz-and-glam-at-the-inaugural-guinness-budo-league-awards/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Glitz and glam at the inaugural Guinness Budo league awards" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1024" data-full-height="683" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/New-Budo-League-president-Aaron-Akampa-speaking-at-the-dinner.-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/New-Budo-League-president-Aaron-Akampa-speaking-at-the-dinner.-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/New-Budo-League-president-Aaron-Akampa-speaking-at-the-dinner.-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/glitz-and-glam-at-the-inaugural-guinness-budo-league-awards/">Glitz and glam at the inaugural Guinness Budo league awards</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139762" data-sequence="6">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Not even rain could stop Tiwa from going Savage at Lugogo" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="992" data-full-height="657" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/">Not even rain could stop Tiwa from going Savage at Lugogo</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139738" data-sequence="7">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/dpp-instructed-to-investigate-conclude-abiriga-kagezi-murders-within-six-months/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="36" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Abiriga&#8217;s murder scene: eye witnesses reconstruct final moments" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1140" data-full-height="540" data-src="https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1.jpeg 1140w, https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1-300x142.jpeg 300w, https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1-768x364.jpeg 768w, https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1-1024x485.jpeg 1024w, https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1-800x379.jpeg 800w, https://nilepost.co.ug/wp-content/uploads/2018/06/Abiriga-car-1-600x284.jpeg 600w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/dpp-instructed-to-investigate-conclude-abiriga-kagezi-murders-within-six-months/">DPP instructed to investigate and conclude Abiriga, Kagezi murders within six months</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139755" data-sequence="8">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/kisoro-nrm-leaders-give-party-flag-to-eddie-kwizera-for-forthcoming-bukimbiri-by-election/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Kisoro NRM leaders  give party flag to Eddie Kwizera for forthcoming Bukimbiri by-election" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1000" data-full-height="818" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/a5fb83f5-e55b-46c2-a542-a032d60c6364-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/a5fb83f5-e55b-46c2-a542-a032d60c6364-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/a5fb83f5-e55b-46c2-a542-a032d60c6364-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/kisoro-nrm-leaders-give-party-flag-to-eddie-kwizera-for-forthcoming-bukimbiri-by-election/">Kisoro NRM leaders give party flag to Eddie Kwizera for forthcoming Bukimbiri by-election</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139752" data-sequence="9">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/heavy-punishments-for-offenders-will-help-curb-human-trafficking-stakeholders-say/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Heavy punishments for offenders will help curb human trafficking, stakeholders say" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="900" data-full-height="600" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/heavy-punishments-for-offenders-will-help-curb-human-trafficking-stakeholders-say/">Heavy punishments for offenders will help curb human trafficking, stakeholders say</a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div><div class="jeg_post jeg_pl_xs_3  " data-id="139733" data-sequence="10">
<div class="jeg_thumb">
<a class="ajax" href="https://nilepost.co.ug/2022/07/31/lawmakers-ask-govt-to-establish-legal-framework-to-protect-domestic-workers/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Lawmakers ask gov&#8217;t to establish legal framework to protect domestic workers " loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="1024" data-full-height="683" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/Members-of-UAERA-inerfacing-with-MPs-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/Members-of-UAERA-inerfacing-with-MPs-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/Members-of-UAERA-inerfacing-with-MPs-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h2 class="jeg_post_title"><a class="ajax" href="https://nilepost.co.ug/2022/07/31/lawmakers-ask-govt-to-establish-legal-framework-to-protect-domestic-workers/">Lawmakers ask gov&#8217;t to establish legal framework to protect domestic workers </a></h2>
<div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 31, 2022</div></div>
</div>
</div> </div>
<div class="sidefeed_loadmore">
<button class="btn " data-end="End of Content" data-loading="Loading..." data-loadmore="Load More">
Load More </button>
</div>
</div>
<div class="jeg_sidefeed_overlay">
<div class='preloader_type preloader_dot'>
<div class="sidefeed-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="sidefeed-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="sidefeed-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_ad jeg_ad_top jnews_header_top_ads">
<div class='ads-wrapper  '><a href='' rel="noopener" class='adlink ads_image '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a><a href='' rel="noopener" class='adlink ads_image_tablet '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a><a href='' rel="noopener" class='adlink ads_image_phone '>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/07/4AD7574C-9F8A-4D79-89E0-21C057C9AC1F.gif' alt='' data-pin-no-hover="true">
</a></div> </div>

<div class="jeg_viewport">
<div class="jeg_header_wrapper">
<div class="jeg_header_instagram_wrapper">
</div>

<div class="jeg_header full">
<div class="jeg_midbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_logo jeg_desktop_logo">
<div class="site-title">
<a href="https://nilepost.co.ug/" style="padding: 0 0 0 0;">
<img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png" srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" alt="Logo" data-light-src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-2-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" data-dark-src="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png" data-dark-srcset="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 1x, http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
<div class='ads-wrapper  '></div></div> </div>
</div>
</div>
</div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_nav_icon">
<a href="#" class="toggle_btn jeg_mobile_toggle">
<span></span><span></span><span></span>
</a>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
<div class="item_wrap jeg_nav_aligncenter">
<div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-115840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115840 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/business/">Business</a></li>
<li id="menu-item-70154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a>
<ul class="sub-menu">
<li id="menu-item-70159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li>
</ul>
</li>
<li id="menu-item-33490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li>
<li id="menu-item-33491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li>
</ul>
</li>
<li id="menu-item-130270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130270 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/politics/">Politics</a></li>
<li id="menu-item-14258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li>
<li id="menu-item-33492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33492 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/security/">Security</a>
<ul class="sub-menu">
<li id="menu-item-130264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130264 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/cyber-security/">Cyber Security</a></li>
</ul>
</li>
<li id="menu-item-115849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115849 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/health-2/">Health</a>
<ul class="sub-menu">
<li id="menu-item-115872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115872 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li>
</ul>
</li>
<li id="menu-item-768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a>
<ul class="sub-menu">
<li id="menu-item-34124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a>
<ul class="sub-menu">
<li id="menu-item-70006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li>
<li id="menu-item-34125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li>
<li id="menu-item-53331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li>
<li id="menu-item-100718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100718 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li>
<li id="menu-item-55490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">But this Year!</a></li>
<li id="menu-item-129114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129114 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/what-did-i-miss/">What Did I Miss?</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-115848" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115848 bgnav" data-item-row="default"><a href="#">Lifestyle</a>
<ul class="sub-menu">
<li id="menu-item-130269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130269 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/hatmahz-kitchen/">Hatmahz Kitchen</a></li>
<li id="menu-item-130268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130268 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/food-hub/">Food Hub</a></li>
<li id="menu-item-130266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130266 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/love-therapist/lets-talk-about-sex/">Let&#8217;s Talk About Sex</a></li>
<li id="menu-item-115861" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-115861 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/entertainment/">Entertainment</a></li>
<li id="menu-item-115851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115851 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/tour-travel/">Tour &amp; Travel</a></li>
<li id="menu-item-115850" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115850 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/love-therapist/">Love Therapist</a></li>
<li id="menu-item-115857" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115857 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/homes/">Homes</a></li>
</ul>
</li>
<li id="menu-item-115843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115843 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/">Global</a>
<ul class="sub-menu">
<li id="menu-item-115832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115832 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li>
<li id="menu-item-115853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115853 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li>
<li id="menu-item-115855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115855 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li>
<li id="menu-item-115854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115854 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li>
<li id="menu-item-115856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115856 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li>
</ul>
</li>
<li id="menu-item-796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a>
<ul class="sub-menu">
<li id="menu-item-798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li>
<li id="menu-item-800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li>
<li id="menu-item-100365" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100365 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/tanzania/">Tanzania</a></li>
<li id="menu-item-799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li>
<li id="menu-item-102325" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102325 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/dr-congo/">DR Congo</a></li>
<li id="menu-item-102326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102326 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/ethiopia/">Ethiopia</a></li>
<li id="menu-item-102327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102327 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/sudan/">Sudan</a></li>
</ul>
</li>
<li id="menu-item-115829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115829 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/technology/">Technology</a></li>
<li id="menu-item-115830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115830 bgnav" data-item-row="default"><a href="#">Special Reports</a>
<ul class="sub-menu">
<li id="menu-item-115845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115845 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li>
<li id="menu-item-115844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115844 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li>
<li id="menu-item-115846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115846 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li>
<li id="menu-item-115847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115847 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li>
<li id="menu-item-115852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115852 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li>
<li id="menu-item-115863" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115863 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li>
<li id="menu-item-115867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115867 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li>
</ul>
</li>
<li id="menu-item-115866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115866 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-115865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115865 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/place-it/">Place-It</a></li>
<li id="menu-item-115868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115868 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li>
<li id="menu-item-115864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115864 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/bundesliga/">Bundesliga</a></li>
<li id="menu-item-115869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115869 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/world-cup/">World Cup</a></li>
</ul>
</li>
<li id="menu-item-115873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115873 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li>
</ul></div></div>
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
<div class="item_wrap jeg_nav_alignright">

<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div> </div>
<div class="jeg_header_sticky">
</div>
<div class="jeg_navbar_mobile_wrapper">
<div class="jeg_navbar_mobile" data-mode="scroll">
<div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
<div class="container">
<div class="jeg_nav_row">
<div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
<div class="item_wrap jeg_nav_alignleft">
<div class="jeg_nav_item jeg_mobile_logo">
<div class="site-title">
<a href="https://nilepost.co.ug/">
<img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png" srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" alt="Logo" data-light-src="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 1x, https://nilepost.co.ug/wp-content/uploads/2021/09/NP-200X64-logo-big-1-1.png 2x" data-dark-src="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png" data-dark-srcset="http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 1x, http://13.244.145.172/wp-content/uploads/2021/09/NP-200X64-logo-big-3.png 2x"> </a>
</div>
</div> </div>
</div>
<div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
<div class="item_wrap jeg_nav_aligncenter">
</div>
</div>
<div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
<div class="item_wrap jeg_nav_alignright">
<div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div> </div>
</div>
</div>
</div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div> </div>
<div class="post-wrapper">
<div class="post-wrap">
<div class="jeg_main ">
<div class="jeg_container">
<div class="jeg_content jeg_singlepage">
<div class="container">
<div class="jeg_ad jeg_article_top jnews_article_top_ads">
<div class='ads-wrapper  '></div> </div>
<div class="jeg_breadcrumbs jeg_breadcrumb_container">
<div id="breadcrumbs"><span class="">
<a href="https://nilepost.co.ug">Home</a>
</span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
<a href="https://nilepost.co.ug/category/entertainment/">Entertainment</a>
</span></div> </div>
<div class="entry-header">
<h1 class="jeg_post_title">MTN, YoTV unveil redesigned YoTV app with more entertainment channels</h1>
<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">
<div class="meta_left">
<div class="jeg_meta_author">
<img data-del="avatar" alt="Amon Katungulu" src='https://nilepost.co.ug/wp-content/uploads/2017/10/np.jpg' class='avatar pp-user-avatar avatar-80 photo ' height='80' width='80' /> <span class="meta_text">by</span>
<a href="https://nilepost.co.ug/author/nilepost/">Amon Katungulu</a> </div>
<div class="jeg_meta_date">
<a href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/">July 31, 2022</a>
</div>
<div class="jeg_meta_category">
<span><span class="meta_text">in</span>
<a href="https://nilepost.co.ug/category/entertainment/" rel="category tag">Entertainment</a> </span>
</div>
<div class="jeg_meta_reading_time">
<span>
Reading Time: 2 mins read
</span>
</div> </div>
<div class="meta_right">
<div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#comments"><i class="fa fa-comment-o"></i> 0</a></div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="jeg_main_content col-md-8">
<div class="jeg_inner_content">
<div class="jeg_featured featured_image"><a href="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:66.8%"><img width="750" height="501" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-featured-750 size-jnews-featured-750 lazyload wp-post-image" alt="MTN, YoTV unveil redesigned YoTV app with more entertainment channels" loading="lazy" sizes="(max-width: 750px) 100vw, 750px" data-full-width="1024" data-full-height="684" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-750x501.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-750x501.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba-768x513.jpg 768w, https://nilepost.co.ug/wp-content/uploads/2022/07/MTNs-Susan-Kayemba.jpg 1024w" data-sizes="auto" data-expand="700" /></div><p class="wp-caption-text">Susan Kayemba</p></a></div>
<div class="jeg_share_top_container"><div class="jeg_share_button clearfix">
<div class="jeg_share_stats">
</div>
<div class="jeg_sharelist">
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' class="jeg_btn-facebook "><i class="fa fa-facebook-official"></i></a><a href="https://twitter.com/intent/tweet?text=MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels&url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' class="jeg_btn-twitter "><i class="fa fa-twitter"></i></a><a href="//api.whatsapp.com/send?text=MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels%0Ahttps%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' data-action="share/whatsapp/share" class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
<div class="entry-content no-share">
<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
<div class="jeg_share_float_container"></div> </div>
<div class="content-inner ">
<p>MTN Uganda in partnership with YOTV channels have unveiled a new state of the art video streaming app.</p>
<p>The new app expands its current offering from a few options to a large variety of live and video-on-demand content covering live TV channels, live radio stations, comedy, music, movies and so much more.</p>
<p>As YOTV evolves into a super entertainment app, it has unveiled several new products including; <strong>Bolingo Extra </strong>that is all about Ugandan music, comedy and reality shows.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_3_ads  "><div class='ads-wrapper align-center '><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image_tablet align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><a href='https://shop.ugandabaati.co.ug/' target="_blank" rel="nofollow noopener" class='adlink ads_image_phone align-center'>
<img src='https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://nilepost.co.ug/wp-content/uploads/2022/06/uganda-baati-ad-june-2022.gif' alt='AD-03' data-pin-no-hover="true">
</a><div class='ads-text'>ADVERTISEMENT</div></div></div>
<p><strong>Muto, </strong>a product designed for Kids’ edutainment (a creative mix of education and entertainment).</p>
<p><strong>Kibanda Express</strong> a Ugandan movies platform has been redesigned and given a better user interface and user experience.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads  "><div class='ads-wrapper align-center '><div class='ads_code'><ins class='dcmads' style='display:inline-block;width:300px;height:250px' data-dcm-placement='N1480557.3185639NILEPOST/B25500986.332636749' data-dcm-rendering-mode='iframe' data-dcm-https-only data-dcm-gdpr-applies='gdpr=${GDPR}' data-dcm-gdpr-consent='gdpr_consent=${GDPR_CONSENT_755}' data-dcm-addtl-consent='addtl_consent=${ADDTL_CONSENT}' data-dcm-ltd='false' data-dcm-resettable-device-id='' data-dcm-app-id=''> <script src='https://www.googletagservices.com/dcm/dcmads.js'></script> </ins></div><div class='ads-text'>ADVERTISEMENT</div></div></div>
<p>A new channel <strong>eMikolo </strong>(that showcases captivating events for the Ugandan audience) has also been introduced.</p>
<p>Customers can now also access <strong>Kibanda Express</strong> without a running YOTV subscription to enable them to enjoy Ugandan Movies on the platform.</p>
<p>&#8220;YOTV app now has the largest collection of content that includes movies, live TV, live Radio, Music, Comedy, Motivational podcasts, Kids entertainment and much more.  Our local video-on-demand options are unrivalled. We couldn’t have done all this without our great partner MTN and of course our brilliant content creators. We are thus excited to engage with more content creators to walk with us this journey including musicians, filmmakers, comedians, and others,&#8221; said YOTV chief executive officer, Aggrey Mugisha.</p>
<p>Susan Kayemba, the MTN Uganda Senior Manager for Digital services said that MTN’s partnership with YoTV is hinged on MTN’s mission to champion local content consumption by offering clients a seamless yet convenient and affordable platform.</p>
<p>&#8220;The potential of YOTV channels to take local content to the world is absolutely undebatable. With the newly unveiled products, we are optimistic that more people will enjoy more Ugandan content. As MTN, we are here to support Ugandan Innovations and YOTV is the epitome of this,&#8221; said Kayemba.</p>
<p>Due to the changes YOTV Channels deemed necessary to adjust the pricing structure upwards with immediate effect.</p>
<p>The increase helps YOTV to sustain the commitment to providing the very best products and services to it’s customers.</p>
<p>One hour of access has changed from Shs 500 to Shs 800. One day of access has changed from Shs 1000 to Shs 1500. One week of access has changed from Shs 5000 to Shs 7500. One month of access has changed from Shs 10,000 to Shs 20000. Please be assured that YOTV Channels has made every effort to keep this increase to a minimum.</p>
<p>YOTV Channels App was launched in February 2020 right at the wake of the Covid-19 global pandemic phenomenon.</p>
<p>&nbsp;</p>
<div class="jeg_post_tags"><span>Tags:</span> <a href="https://nilepost.co.ug/tag/mtn/" rel="tag">MTN</a><a href="https://nilepost.co.ug/tag/susan-kayemba/" rel="tag">susan kayemba</a><a href="https://nilepost.co.ug/tag/yotv/" rel="tag">yotv</a></div>
</div>
</div>
<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
<div class="jeg_sharelist">
<a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels&url=https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a><a href="//api.whatsapp.com/send?text=MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels%0Ahttps%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" rel='nofollow' class="jeg_btn-whatsapp expanded"><i class="fa fa-whatsapp"></i><span>Send</span></a>
</div>
</div></div>
<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
<a href="https://nilepost.co.ug/2022/07/31/lawmakers-ask-govt-to-establish-legal-framework-to-protect-domestic-workers/" class="post prev-post">
<span class="caption">Previous Post</span>
<h3 class="post-title">Lawmakers ask gov&#8217;t to establish legal framework to protect domestic workers </h3>
</a>
<a href="https://nilepost.co.ug/2022/07/31/heavy-punishments-for-offenders-will-help-curb-human-trafficking-stakeholders-say/" class="post next-post">
<span class="caption">Next Post</span>
<h3 class="post-title">Heavy punishments for offenders will help curb human trafficking, stakeholders say</h3>
</a>
</div></div><div class="jnews_author_box_container ">
<div class="jeg_authorbox">
<div class="jeg_author_image">
<img data-del="avatar" alt="Amon Katungulu" src='https://nilepost.co.ug/wp-content/uploads/2017/10/np.jpg' class='avatar pp-user-avatar avatar-80 photo ' height='80' width='80' /> </div>
<div class="jeg_author_content">
<h3 class="jeg_author_name">
<a href="https://nilepost.co.ug/author/nilepost/">
Amon Katungulu </a>
</h3>
<p class="jeg_author_desc">
</p>
<div class="jeg_author_socials">
<a target='_blank' href='http://www.nilepost.co.ug' class='url'><i class='fa fa-globe'></i> </a>
<a target='_blank' href='http://@nilepostnews' class='twitter'><i class='fa fa-twitter'></i> </a>
</div>
</div>
</div>
</div><div class="jnews_related_post_container"><div class="jeg_postblock_3 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_139734_0_62e67991b024d   " data-unique="jnews_module_139734_0_62e67991b024d">
<div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right">
<h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
</div>
<div class="jeg_posts jeg_block_container">
<div class="jeg_posts jeg_load_more_flag">
<article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Girl power, umbrellas and Cider dominate Tiwa Savage concert" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="936" data-full-height="620" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-350x250.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-750x536.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/">Girl power, umbrellas and Cider dominate Tiwa Savage concert</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/nilepost/">Amon Katungulu</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/"><i class="fa fa-clock-o"></i> July 31, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>An all-female line-up, a rainy night and a vibrant Tusker Cider experience dominated the ‘Tiwa Savage Live in Kampala’ concert...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Not even rain could stop Tiwa from going Savage at Lugogo" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="992" data-full-height="657" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-350x250.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_2171-750x536.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/">Not even rain could stop Tiwa from going Savage at Lugogo</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/"><i class="fa fa-clock-o"></i> July 31, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/07/31/not-even-rain-could-stop-tiwa-from-going-savage-at-lugogo/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>For over an hour on Friday night at the Tusker Cider-sponsored ‘Tiwa Live in Kampala’ show at the Lugogo Cricket...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/29/tiwa-savage-says-cant-wait-to-perform-at-lugogo-today/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Tiwa Savage says can&#8217;t wait to perform at Lugogo today" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="992" data-full-height="657" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/0-21-350x250.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/0-21-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/0-21-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/0-21-750x536.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/07/29/tiwa-savage-says-cant-wait-to-perform-at-lugogo-today/">Tiwa Savage says can&#8217;t wait to perform at Lugogo today</a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/07/29/tiwa-savage-says-cant-wait-to-perform-at-lugogo-today/"><i class="fa fa-clock-o"></i> July 29, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/07/29/tiwa-savage-says-cant-wait-to-perform-at-lugogo-today/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>Nigerian Afro-beats singer,  Dr.Tiwa Savage has landed into the country ahead of today's concert at  the Lugogo Cricket Oval alongside...</p>
</div>
</div>
</article><article class="jeg_post jeg_pl_md_2 format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/28/government-to-inject-shs-3-billion-in-local-film-industry/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Government to inject Shs 3 billion in local film industry " loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-full-width="1024" data-full-height="683" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/Peace-Mutuuzo-350x250.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/Peace-Mutuuzo-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/Peace-Mutuuzo-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/Peace-Mutuuzo-750x536.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title">
<a href="https://nilepost.co.ug/2022/07/28/government-to-inject-shs-3-billion-in-local-film-industry/">Government to inject Shs 3 billion in local film industry </a>
</h3>
<div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/muhamad/">Muhamadi Matovu</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2022/07/28/government-to-inject-shs-3-billion-in-local-film-industry/"><i class="fa fa-clock-o"></i> July 28, 2022</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2022/07/28/government-to-inject-shs-3-billion-in-local-film-industry/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div>
<div class="jeg_post_excerpt">
<p>The Minister of State for Gender and Culture, Peace Mutuuzo has revealed that over the next five years, government will...</p>
</div>
</div>
</article>
</div>
<div class='module-overlay'>
<div class='preloader_type preloader_dot'>
<div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="module-preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="module-preloader jeg_preloader square">
<div class="jeg_square">
<div class="jeg_square_inner"></div>
</div>
</div>
</div>
</div>
</div>
<div class="jeg_block_navigation">
<div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
</div>
<script>var jnews_module_139734_0_62e67991b024d = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"4","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":139734,"include_category":"106537","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","job_listing_type":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":3,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_3"};</script>
</div></div><div class="jnews_popup_post_container"> <section class="jeg_popup_post">
<span class="caption">Next Post</span>
<div class="jeg_popup_content">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/heavy-punishments-for-offenders-will-help-curb-human-trafficking-stakeholders-say/">
<div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Heavy punishments for offenders will help curb human trafficking, stakeholders say" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-full-width="900" data-full-height="600" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-75x75.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-75x75.jpg 75w, https://nilepost.co.ug/wp-content/uploads/2022/07/pledge-350x350.jpg 350w" data-sizes="auto" data-expand="700" /></div> </a>
</div>
<h3 class="post-title">
<a href="https://nilepost.co.ug/2022/07/31/heavy-punishments-for-offenders-will-help-curb-human-trafficking-stakeholders-say/">
Heavy punishments for offenders will help curb human trafficking, stakeholders say </a>
</h3>
</div>
<a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
</section>
</div><div class="jnews_comment_container"> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/07/31/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://nilepost.co.ug/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<div class="gglcptch gglcptch_v2"><div id="gglcptch_recaptcha_504714555" class="gglcptch_recaptcha"></div>
<noscript>
<div style="width: 302px;">
<div style="width: 302px; height: 422px; position: relative;">
<div style="width: 302px; height: 422px; position: absolute;">
<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcyQYYcAAAAAI7vvUVrJ_ZK7Oo7YMTjSbd0FAmg" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
</div>
</div>
<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
</div>
</div>
</noscript></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='139734' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div> </div>
</div>
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
<div class="widget widget_jnews_tab_post" id="jnews_tab_post-21"><div class="jeg_tabpost_widget"><ul class="jeg_tabpost_nav">
<li data-tab-content="jeg_tabpost_1" class="active">Trending</li>
<li data-tab-content="jeg_tabpost_2">Comments</li>
<li data-tab-content="jeg_tabpost_3">Latest</li>
</ul><div class="jeg_tabpost_content"><div class="jeg_tabpost_item active" id="jeg_tabpost_1"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/25/student-who-was-forcefully-vaccinated-against-covid-19-dies/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="14 year old student suffers multiple organ failure after receiving Covid-19 vaccine" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1024" data-full-height="509" data-src="https://nilepost.co.ug/wp-content/uploads/2022/06/Luyinda-Jonah-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/06/Luyinda-Jonah-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/06/Luyinda-Jonah-350x250.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/07/25/student-who-was-forcefully-vaccinated-against-covid-19-dies/">Student who was &#8216;forcefully&#8217; vaccinated against Covid-19 dies</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 25, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/26/putin-sends-a-special-message-to-museveni/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Putin sends a special message to Museveni" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="2560" data-full-height="1707" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/President-Museveni-meeting-Russias-Foreign-Minister-Sergey-Lavrov-and-his-delegation-at-State-House-Entebbe-on-Tuesday-July-26-2022.-Sergey-is-in-Uganda-on-a-two-day-working-visit.-PPU-Photo-2-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/President-Museveni-meeting-Russias-Foreign-Minister-Sergey-Lavrov-and-his-delegation-at-State-House-Entebbe-on-Tuesday-July-26-2022.-Sergey-is-in-Uganda-on-a-two-day-working-visit.-PPU-Photo-2-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/President-Museveni-meeting-Russias-Foreign-Minister-Sergey-Lavrov-and-his-delegation-at-State-House-Entebbe-on-Tuesday-July-26-2022.-Sergey-is-in-Uganda-on-a-two-day-working-visit.-PPU-Photo-2-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/President-Museveni-meeting-Russias-Foreign-Minister-Sergey-Lavrov-and-his-delegation-at-State-House-Entebbe-on-Tuesday-July-26-2022.-Sergey-is-in-Uganda-on-a-two-day-working-visit.-PPU-Photo-2-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2022/07/President-Museveni-meeting-Russias-Foreign-Minister-Sergey-Lavrov-and-his-delegation-at-State-House-Entebbe-on-Tuesday-July-26-2022.-Sergey-is-in-Uganda-on-a-two-day-working-visit.-PPU-Photo-2-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/07/26/putin-sends-a-special-message-to-museveni/">Putin sends a special message to Museveni</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> July 26, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2021/04/29/top-10-african-countries-with-exceptionally-beautiful-women/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Top 10 African countries with exceptionally beautiful women" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="600" data-full-height="443" data-src="https://nilepost.co.ug/wp-content/uploads/2021/04/Rwandas-beautiful-ladies-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/04/Rwandas-beautiful-ladies-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/04/Rwandas-beautiful-ladies-350x250.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2021/04/29/top-10-african-countries-with-exceptionally-beautiful-women/">Top 10 African countries with exceptionally beautiful women</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_date"><i class="fa fa-clock-o"></i> April 29, 2021</div>
</div>
</div>
</div></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_2"><div class="jegwidgetpopular"></div></div><div class="jeg_tabpost_item" id="jeg_tabpost_3"><div class="jegwidgetpopular"><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/10-dead-scores-missing-as-floods-hit-eastern-uganda/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="10 dead, scores missing as floods hit eastern Uganda" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="645" data-full-height="1165" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/FY-uhjMWIAMBmiv-350x250.jpg 350w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/07/31/10-dead-scores-missing-as-floods-hit-eastern-uganda/">10 dead, scores missing as floods hit eastern Uganda</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> July 31, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Girl power, umbrellas and Cider dominate Tiwa Savage concert" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="936" data-full-height="620" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-120x86.jpg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/SAM_1725-750x536.jpg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/07/31/girl-power-umbrellas-and-cider-dominate-tiwa-savage-concert/">Girl power, umbrellas and Cider dominate Tiwa Savage concert</a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> July 31, 2022</div>
</div>
</div>
</div><div class="jeg_post jeg_pl_sm format-standard">
<div class="jeg_thumb">
<a href="https://nilepost.co.ug/2022/07/31/eddie-kwizera-chosen-as-nrm-party-flag-bearer-but-challenger-cries-foul/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Eddie Kwizera chosen as NRM party flag bearer but challenger cries foul " loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1080" data-full-height="720" data-src="https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-120x86.jpeg" data-srcset="https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-350x250.jpeg 350w, https://nilepost.co.ug/wp-content/uploads/2022/07/Eddie-Kwizera-receives-the-NRM-flag-from-Baryomunsi-750x536.jpeg 750w" data-sizes="auto" data-expand="700" /></div></a>
</div>
<div class="jeg_postblock_content">
<h3 class="jeg_post_title"><a property="url" href="https://nilepost.co.ug/2022/07/31/eddie-kwizera-chosen-as-nrm-party-flag-bearer-but-challenger-cries-foul/">Eddie Kwizera chosen as NRM party flag bearer but challenger cries foul </a></h3>
<div class="jeg_post_meta">
<div class="jeg_meta_like"><i class="fa fa-clock-o"></i> July 31, 2022</div>
</div>
</div>
</div></div></div></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-35"><div class='jeg_ad jeg_ad_module jnews_module_139734_1_62e6799209edd   '><div class='ads-wrapper'></div></div></div></div> </div>
<div class="jeg_ad jeg_article jnews_article_bottom_ads">
<div class='ads-wrapper  '></div> </div>
</div>
</div>
</div>
</div>
<div id="post-body-class" class="post-template-default single single-post postid-139734 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jeg_sidecontent jeg_sidecontent_left jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.9.0 vc_responsive"></div>
</div>
<div class="post-ajax-overlay">
<div class="preloader_type preloader_dot">
<div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span>
</div>
<div class="newsfeed_preloader jeg_preloader circle">
<div class="jnews_preloader_circle_outer">
<div class="jnews_preloader_circle_inner"></div>
</div>
</div>
<div class="newsfeed_preloader jeg_preloader square">
<div class="jeg_square"><div class="jeg_square_inner"></div></div>
</div>
</div>
</div>
</div>
<div class="footer-holder" id="footer" data-id="footer">
<div class="jeg_footer jeg_footer_4 normal">
<div class="jeg_footer_container jeg_container">
<div class="jeg_footer_content">
<div class="container">
<div class="row">
<div class="jeg_footer_primary clearfix">
<div class="col-md-9 footer_column">
<ul class="jeg_menu_footer"><li id="menu-item-119307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119307"><a href="#">About</a></li>
<li id="menu-item-119308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119308"><a href="#">Advertise</a></li>
<li id="menu-item-119309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119309"><a href="#">Privacy &#038; Policy</a></li>
<li id="menu-item-119310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119310"><a href="https://nilepost.co.ug/jobs/">Careers</a></li>
</ul> </div>
<div class="col-md-3 footer_column footer_right">
<div class="footer-text">
<strong> Call us: +256-417-720-101</strong><br>
<strong> Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6702030e1308150e060b27090e0b0217081413490408491200">[email&#160;protected]</a> </div>
</div>
</div>
<div class="jeg_footer_secondary clearfix">
<div class="col-md-9 footer_column">
<p class="copyright"> © 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company. </p>
</div>
<div class="col-md-3 footer_column footer_right">
<div class="jeg_social_icon_block socials_widget nobg">
<a href="https://www.facebook.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div> </div>
<div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
</div>
</div>

<div id="jeg_off_canvas" class="normal">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
<div class="jeg_bg_overlay"></div>
<div class="jeg_mobile_wrapper">
<div class="nav_wrap">
<div class="item_main">

<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
<form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>

<div class="jeg_search_result jeg_search_hide with_result">
<div class="search-result-wrapper">
</div>
<div class="search-link search-noresult">
No Result </div>
<div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result </div>
</div></div><div class="jeg_aside_item">
<ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765"><a href="https://nilepost.co.ug/category/news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115840"><a href="https://nilepost.co.ug/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130270"><a href="https://nilepost.co.ug/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33492"><a href="https://nilepost.co.ug/category/news/security/">Security</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130264"><a href="https://nilepost.co.ug/category/cyber-security/">Cyber Security</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115849"><a href="https://nilepost.co.ug/category/health-2/">Health</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115872"><a href="https://nilepost.co.ug/category/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100718"><a href="https://nilepost.co.ug/category/opinions/columns/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">But this Year!</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129114"><a href="https://nilepost.co.ug/category/what-did-i-miss/">What Did I Miss?</a></li>
</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115848"><a href="#">Lifestyle</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130269"><a href="https://nilepost.co.ug/category/hatmahz-kitchen/">Hatmahz Kitchen</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130268"><a href="https://nilepost.co.ug/category/food-hub/">Food Hub</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130266"><a href="https://nilepost.co.ug/category/love-therapist/lets-talk-about-sex/">Let&#8217;s Talk About Sex</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-115861"><a href="https://nilepost.co.ug/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115851"><a href="https://nilepost.co.ug/category/tour-travel/">Tour &amp; Travel</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115850"><a href="https://nilepost.co.ug/category/love-therapist/">Love Therapist</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115857"><a href="https://nilepost.co.ug/category/homes/">Homes</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115843"><a href="https://nilepost.co.ug/category/global-watch/">Global</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115832"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115853"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115855"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115854"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115856"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-100365"><a href="https://nilepost.co.ug/category/east-africa/tanzania/">Tanzania</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102325"><a href="https://nilepost.co.ug/category/east-africa/dr-congo/">DR Congo</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102326"><a href="https://nilepost.co.ug/category/east-africa/ethiopia/">Ethiopia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102327"><a href="https://nilepost.co.ug/category/east-africa/sudan/">Sudan</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115829"><a href="https://nilepost.co.ug/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-115830"><a href="#">Special Reports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115845"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115844"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115846"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115847"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115852"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115863"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115867"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-115866"><a href="https://nilepost.co.ug/category/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115865"><a href="https://nilepost.co.ug/category/place-it/">Place-It</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115868"><a href="https://nilepost.co.ug/category/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115864"><a href="https://nilepost.co.ug/category/bundesliga/">Bundesliga</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115869"><a href="https://nilepost.co.ug/category/world-cup/">World Cup</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115873"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li>
</ul></div> </div>
<div class="item_bottom">
<div class="jeg_aside_item socials_widget circle">
<a href="https://www.facebook.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' rel='external noopener nofollow' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
<p>© 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company.</p>
</div> </div>
</div> </div>
</div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var jfla = ["view_counter"]</script><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
<div class="pswp__bg"></div>
<div class="pswp__scroll-wrap">
<div class="pswp__container">
<div class="pswp__item"></div>
<div class="pswp__item"></div>
<div class="pswp__item"></div>
</div>
<div class="pswp__ui pswp__ui--hidden">
<div class="pswp__top-bar">
<div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
<div class="pswp__preloader">
<div class="pswp__preloader__icn">
<div class="pswp__preloader__cut">
<div class="pswp__preloader__donut"></div>
</div>
</div>
</div>
</div>
<div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
<div class="pswp__share-tooltip"></div>
</div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button>
<div class="pswp__caption">
<div class="pswp__caption__center"></div>
</div>
</div>
</div>
</div><div id="selectShareContainer">
<div class="selectShare-inner">
<div class="select_share jeg_share_button">
<button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" data-image-url="" data-title="MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels"><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fnilepost.co.ug%2F2022%2F07%2F31%2Fmtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels%2F" data-image-url="" data-title="MTN%2C%20YoTV%20unveil%20redesigned%20YoTV%20app%20with%20more%20entertainment%20channels"><i class="fa fa-twitter"></i></a>
</div>
<div class="selectShare-arrowClip">
<div class="selectShare-arrow"></div>
</div>
</div>
</div><div class="jeg_read_progress_wrapper"></div>
<link rel="stylesheet" type="text/css" href="//nilepost.co.ug/wp-content/cache/wpfc-minified/2frvua3x/7tl5c.css" media="all" />
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"94b401406e","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.15' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/photoswipe/photoswipe.js?ver=10.0.3' id='photoswipe-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/photoswipe/photoswipe-ui-default.js?ver=10.0.3' id='photoswipe-ui-default-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/nilepost.co.ug\/2022\/07\/31\/mtn-yotv-unveil-redesigned-yotv-app-with-more-entertainment-channels","popup_script":"photoswipe","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"139734","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"nilepost.co.ug","zoom_button":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=10.0.3' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.0.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit&#038;ver=1.67' id='gglcptch_api-js'></script>
<script type='text/javascript' id='gglcptch_script-js-extra'>
/* <![CDATA[ */
var gglcptch = {"options":{"version":"v2","sitekey":"6LcyQYYcAAAAAI7vvUVrJ_ZK7Oo7YMTjSbd0FAmg","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":1,"theme":"light"},"vars":{"visibility":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://nilepost.co.ug/wp-content/plugins/google-captcha/js/script.js?ver=1.67' id='gglcptch_script-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(e.data.counter,(function(e,n){o[n].length&&t.forEach(o[n],(function(n,o){t.setText(n,e)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script><script>(function(){var js = "window['__CF$cv$params']={r:'73379eb77e4e9c4e',m:'L0DVvCJeBSVfpF.2S7S5rtnKXXtbnYDaAZ0DyCDHV7g-1659283992-0-AbaGlQipmLXEwqQ0E3RFc+fiYoGFs+schoPiBJPjGd6BDmZMUG4jljiGtKnpCbi2REqUfe4DOF8qHk0MjNjf4Q2Glag9+gbtT9qGcjtU7RiitfmNysXIMA74ts5F4idnSpYfNCVs49sq5c+VHWI5PWPe+t/1iH+ceFSR8ciyd10kPpcBRlYuusLEFSQtFKR0v3bd61/E6urTpFM8ZbnrlZgA6Ikee0N68vcNfuNhdRrX',s:[0xf7d1dce386,0xdfaba5a7a5],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>