<!doctype html><!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" > <![endif]--><!--[if IE 7]> <html class="no-js lt-ie9 lt-ie8" lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" > <![endif]--><!--[if IE 8]> <html class="no-js lt-ie9" lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" > <![endif]--><!--[if IE 9]> <html class="no-js lt-ie10" lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" > <![endif]--><!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"> <!--<![endif]--><head> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://nilepost.co.ug/xmlrpc.php" /> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <script type="text/javascript"> var jnews_ajax_url = 'https://nilepost.co.ug/?ajax-request=jnews'; </script> <title>Owiny Dollo&#039;s full speech at the fourth Benedcito Kiwanuka Memorial - Nile Post</title><meta name="description" content="Nile Post - Owiny Dollo&#039;s full speech at the fourth Benedcito Kiwanuka Memorial Opinions" /><link rel="canonical" href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Owiny Dollo&#039;s full speech at the fourth Benedcito Kiwanuka Memorial - Nile Post" /><meta property="og:description" content="Nile Post - Owiny Dollo&#039;s full speech at the fourth Benedcito Kiwanuka Memorial Opinions" /><meta property="og:url" content="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/" /><meta property="og:site_name" content="Nile Post" /><meta property="article:publisher" content="https://www.facebook.com/nilepostnews/" /><meta property="article:published_time" content="2021-10-25T04:53:51+00:00" /><meta property="og:image" content="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg" /><meta property="og:image:width" content="900" /><meta property="og:image:height" content="485" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@nilepostnews" /><meta name="twitter:site" content="@nilepostnews" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="NP admin" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="7 minutes" /><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://nilepost.co.ug/#organization","name":"Nile Post","url":"https://nilepost.co.ug/","sameAs":["https://www.facebook.com/nilepostnews/","https://twitter.com/nilepostnews"],"logo":{"@type":"ImageObject","@id":"https://nilepost.co.ug/#logo","inLanguage":"en-US","url":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2018/06/NilePost-Logo.png","width":600,"height":173,"caption":"Nile Post"},"image":{"@id":"https://nilepost.co.ug/#logo"}},{"@type":"WebSite","@id":"https://nilepost.co.ug/#website","url":"https://nilepost.co.ug/","name":"Nile Post","description":"Accurate news fast","publisher":{"@id":"https://nilepost.co.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://nilepost.co.ug/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#primaryimage","inLanguage":"en-US","url":"https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg","width":900,"height":485,"caption":"Alphonse Owiny Dollo"},{"@type":"WebPage","@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#webpage","url":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/","name":"Owiny Dollo's full speech at the fourth Benedcito Kiwanuka Memorial - Nile Post","isPartOf":{"@id":"https://nilepost.co.ug/#website"},"primaryImageOfPage":{"@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#primaryimage"},"datePublished":"2021-10-25T04:53:51+00:00","dateModified":"2021-10-25T04:53:51+00:00","description":"Nile Post - Owiny Dollo's full speech at the fourth Benedcito Kiwanuka Memorial Opinions","breadcrumb":{"@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/"]}]},{"@type":"BreadcrumbList","@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://nilepost.co.ug/"},{"@type":"ListItem","position":2,"name":"Blog","item":"https://nilepost.co.ug/blog/"},{"@type":"ListItem","position":3,"name":"Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial"}]},{"@type":"Article","@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#article","isPartOf":{"@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#webpage"},"author":{"@id":"https://nilepost.co.ug/#/schema/person/f6ce91aebf99300e58e636d4fefc0178"},"headline":"Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial","datePublished":"2021-10-25T04:53:51+00:00","dateModified":"2021-10-25T04:53:51+00:00","mainEntityOfPage":{"@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#webpage"},"wordCount":1556,"commentCount":0,"publisher":{"@id":"https://nilepost.co.ug/#organization"},"image":{"@id":"https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#primaryimage"},"thumbnailUrl":"https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg","keywords":["Alfonse \u00a0Owiny-Dollo","benedicto kiwanuka memorial"],"articleSection":["Opinions"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/#respond"]}]},{"@type":"Person","@id":"https://nilepost.co.ug/#/schema/person/f6ce91aebf99300e58e636d4fefc0178","name":"NP admin","image":{"@type":"ImageObject","@id":"https://nilepost.co.ug/#personlogo","inLanguage":"en-US","url":"https://nilepost.co.ug/wp-content/uploads/2020/01/download.png","contentUrl":"https://nilepost.co.ug/wp-content/uploads/2020/01/download.png","caption":"NP admin"},"url":"https://nilepost.co.ug/author/admin/"}]}</script><link rel='dns-prefetch' href='//s7.addthis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Feed" href="https://nilepost.co.ug/feed/" /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Comments Feed" href="https://nilepost.co.ug/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial Comments Feed" href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/feed/" /><link rel="https://api.w.org/" href="https://nilepost.co.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://nilepost.co.ug/wp-json/wp/v2/posts/119226" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nilepost.co.ug/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nilepost.co.ug/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 5.7.3" /><link rel='shortlink' href='https://nilepost.co.ug/?p=119226' /><link rel="alternate" type="application/json+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2021%2F10%2F25%2Fowiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial%2F" /><link rel="alternate" type="text/xml+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2021%2F10%2F25%2Fowiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.43.0" /><meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236"><meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com"><style>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</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /><style type="text/css">#wp-admin-bar-pvc-post-views .pvc-graph-container{padding-top:6px;padding-bottom:6px;position:relative;display:block;height:100%;box-sizing:border-box}#wp-admin-bar-pvc-post-views .pvc-line-graph{display:inline-block;width:1px;margin-right:1px;background-color:#ccc;vertical-align:baseline}#wp-admin-bar-pvc-post-views .pvc-line-graph:hover{background-color:#eee}#wp-admin-bar-pvc-post-views .pvc-line-graph-0{height:1%}#wp-admin-bar-pvc-post-views .pvc-line-graph-1{height:5%}#wp-admin-bar-pvc-post-views .pvc-line-graph-2{height:10%}#wp-admin-bar-pvc-post-views .pvc-line-graph-3{height:15%}#wp-admin-bar-pvc-post-views .pvc-line-graph-4{height:20%}#wp-admin-bar-pvc-post-views .pvc-line-graph-5{height:25%}#wp-admin-bar-pvc-post-views .pvc-line-graph-6{height:30%}#wp-admin-bar-pvc-post-views .pvc-line-graph-7{height:35%}#wp-admin-bar-pvc-post-views .pvc-line-graph-8{height:40%}#wp-admin-bar-pvc-post-views .pvc-line-graph-9{height:45%}#wp-admin-bar-pvc-post-views .pvc-line-graph-10{height:50%}#wp-admin-bar-pvc-post-views .pvc-line-graph-11{height:55%}#wp-admin-bar-pvc-post-views .pvc-line-graph-12{height:60%}#wp-admin-bar-pvc-post-views .pvc-line-graph-13{height:65%}#wp-admin-bar-pvc-post-views .pvc-line-graph-14{height:70%}#wp-admin-bar-pvc-post-views .pvc-line-graph-15{height:75%}#wp-admin-bar-pvc-post-views .pvc-line-graph-16{height:80%}#wp-admin-bar-pvc-post-views .pvc-line-graph-17{height:85%}#wp-admin-bar-pvc-post-views .pvc-line-graph-18{height:90%}#wp-admin-bar-pvc-post-views .pvc-line-graph-19{height:95%}#wp-admin-bar-pvc-post-views .pvc-line-graph-20{height:100%}</style><script src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5725099935220167" crossorigin="anonymous" type="text/javascript"></script><link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy-75x75.png" sizes="32x32" /><link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" /><meta name="msapplication-TileImage" content="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" /><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display:none}</style><noscript><style> .wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-119226 single-format-standard wp-megamenu jeg_single_tpl_1 jnews jeg_boxed jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"> <div class="jeg_ad jeg_ad_top jnews_header_top_ads"> <div class='ads-wrapper '></div> </div> <div class="jeg_viewport"> <div class="jeg_header_wrapper"> <div class="jeg_header_instagram_wrapper"> </div><div class="jeg_header full"> <div class="jeg_midbar jeg_container normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://nilepost.co.ug/" style="padding: 0px 0px 0px 0px;"> <img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" alt="Nile Post" data-light-src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" data-dark-src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x"> </a> </div></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads"> <div class='ads-wrapper '><div class='ads_code'><IFRAME SRC="https://ad.doubleclick.net/ddm/adi/N1480557.3185639NILEPOST/B25500986.298696060;sz=728x90;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;gdpr=${GDPR};gdpr_consent=${GDPR_CONSENT_755}?" WIDTH=728 HEIGHT=90 MARGINWIDTH=0 MARGINHEIGHT=0 HSPACE=0 VSPACE=0 FRAMEBORDER=0 SCROLLING=no BORDERCOLOR='#000000'> <script language='JavaScript1.1' SRC="https://ad.doubleclick.net/ddm/adj/N1480557.3185639NILEPOST/B25500986.298696060;abr=!ie;sz=728x90;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;gdpr=${GDPR};gdpr_consent=${GDPR_CONSENT_755}?"> </script> </IFRAME></div><div class='ads-text'>ADVERTISEMENT</div></div></div> </div> </div> </div> </div></div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_nav_icon"> <a href="#" class="toggle_btn jeg_mobile_toggle"> <span></span><span></span><span></span> </a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li id="menu-item-70154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a><ul class="sub-menu"><li id="menu-item-70159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li></ul></li><li id="menu-item-14258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li id="menu-item-33490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li id="menu-item-33491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li id="menu-item-33492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li id="menu-item-33668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/business/">Business</a></li><li id="menu-item-768" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-768 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li id="menu-item-34124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li id="menu-item-70006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li><li id="menu-item-34125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li id="menu-item-53331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li id="menu-item-55490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">Week in Ugandan News</a></li><li id="menu-item-116682" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116682 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li></ul></li></ul></li><li id="menu-item-14629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li id="menu-item-14628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li id="menu-item-33864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li id="menu-item-33866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li id="menu-item-33865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li id="menu-item-33867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li id="menu-item-796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li id="menu-item-798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li id="menu-item-800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li id="menu-item-799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li id="menu-item-33497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497 bgnav" data-item-row="default"><a href="#">Lifestyle</a><ul class="sub-menu"><li id="menu-item-55232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li id="menu-item-33498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33498 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a><ul class="sub-menu"><li id="menu-item-70763" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70763 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li></ul></li><li id="menu-item-33500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &amp; Travel</a></li><li id="menu-item-33499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li id="menu-item-33868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li id="menu-item-3344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li id="menu-item-3727" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727 bgnav" data-item-row="default"><a href="#">Special Reports</a><ul class="sub-menu"><li id="menu-item-33486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li id="menu-item-33485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li id="menu-item-33487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li id="menu-item-33489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li id="menu-item-33501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li id="menu-item-2706" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li id="menu-item-33488" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li id="menu-item-17600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-14633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li id="menu-item-33495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li id="menu-item-14632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li id="menu-item-33496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li id="menu-item-76426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76426 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li><li id="menu-item-33507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/live/">Archives</a></li><li id="menu-item-77189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77189 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/live-updates/"><i style='color: #dd3333' class='jeg_font_menu fa fa-video-camera'></i>Live</a></li></ul></div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Results Found </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Results </div></div></div> </div> </div> </div> </div></div></div> </div> <div class="jeg_header_sticky"> <div class="sticky_blankspace"></div><div class="jeg_header full"> <div class="jeg_container"> <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_nav_icon"> <a href="#" class="toggle_btn jeg_mobile_toggle"> <span></span><span></span><span></span> </a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-768 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">Week in Ugandan News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116682 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li></ul></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497 bgnav" data-item-row="default"><a href="#">Lifestyle</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33498 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70763 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &amp; Travel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727 bgnav" data-item-row="default"><a href="#">Special Reports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76426 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/category/live/">Archives</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77189 bgnav" data-item-row="default"><a href="https://nilepost.co.ug/live-updates/"><i style='color: #dd3333' class='jeg_font_menu fa fa-video-camera'></i>Live</a></li></ul></div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Results Found </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Results </div></div></div> </div> </div> </div></div> </div> </div></div> </div> <div class="jeg_navbar_mobile_wrapper"> <div class="jeg_navbar_mobile" data-mode="scroll"> <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_normal"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_grow"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://nilepost.co.ug/"> <img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" alt="Nile Post" data-light-src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" data-dark-src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x"> </a> </div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_normal"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Results Found </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Results </div></div></div> </div> </div> </div> </div></div></div><div class="sticky_blankspace" style="height: 60px;"></div> </div> <div class="post-wrapper"> <div class="post-wrap"> <div class="jeg_main jeg_double_sidebar"> <div class="jeg_container"> <div class="jeg_content jeg_singlepage"> <div class="container"> <div class="jeg_ad jeg_article jnews_article_top_ads"> <div class='ads-wrapper '></div> </div> <div class="row"> <div class="jeg_main_content col-md-6"> <div class="jeg_inner_content"> <div class="entry-header"> <h1 class="jeg_post_title">Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial</h1> <h2 class="jeg_post_subtitle">Judiciary must always advance the rule of law, says CJ</h2> <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1"> <div class="meta_left"> <div class="jeg_meta_author"> <img data-del="avatar" alt="NP admin" src='https://nilepost.co.ug/wp-content/uploads/2020/01/download.png' class='avatar pp-user-avatar avatar-80 photo ' height='80' width='80' /> <span class="meta_text">by</span> <a href="https://nilepost.co.ug/author/admin/">NP admin</a> </div> <div class="jeg_meta_date"> <a href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/">October 25, 2021 at 7:53 am</a> </div> <div class="jeg_meta_category"> <span><span class="meta_text">in</span> <a href="https://nilepost.co.ug/category/opinions/" rel="category tag">Opinions</a> </span> </div> </div> <div class="meta_right"> </div></div></div> </div> <div class="jeg_featured featured_image"><a href="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg"><div class="thumbnail-container animate-lazy" style="padding-bottom:53.867%"><img width="750" height="404" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-featured-750 size-jnews-featured-750 lazyload wp-post-image" alt="Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-750x404.jpeg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-750x404.jpeg 750w, https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-768x414.jpeg 768w, https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo.jpeg 900w" data-expand="700" /></div><p class="wp-caption-text">Alphonse Owiny Dollo</p></a></div> <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper '></div></div> <div class="entry-content no-share"> <div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome"> </div> <div class="content-inner "> <div class="at-above-post addthis_tool" data-url="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/"></div><p>On behalf of the Judiciary of Uganda, which I am privileged to head, I take this opportunity to profusely thank Your Excellency for personally gracing the 4th Annual Benedicto Kiwanuka Memorial, despite your very busy schedule.</p><p>I also warmly welcome all the other distinguished persons here present on this occasion.</p><p>I believe a host of Judicial officers, other members of the legal fraternity, and other esteemed Ugandans are remotely, but keenly following these proceedings via Speech by CJ – Benedicto Kiwanuka Memorial, 2021<br />technological innovation.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads "><div class='ads-wrapper align-right '></div></div><p>I appreciate your individual participation in this function which is of enormous importance to the Judiciary and the entire country.</p><p>It was 49 years ago, last week, specifically on the 21st September, when operatives of the ignoble regime of Idi Amin crudely and blatantly abducted Chief Justice Benedicto Kiwanuka &#8211; the first Ugandan national<br />to become Chief Justice of Uganda – from his Chambers in the High Court Building, and ‘disappeared’ him.</p><p>The Judiciary of Uganda has, for the 4th successive year running now, accorded the indomitable fallen<br />Chief Justice a deserving memorial in honour and recognition of his remarkable contribution to multiple facets of the Ugandan society of his time, as a private legal practitioner, politician and statesman who cherished living in a country governed on the basis of a democratic dispensation, and observance of the rule of law, and respect for human rights, and as a judicial officer where his commendable career pursuit was cut short by forces of evil because of his uncompromising stance on the issues of justice and rule of law, and defence of human rights, for which he paid the ultimate price.</p><p>The theme for this year’s memorial: Administration and Delivery of Justice through the Years”, is derived from the Book by Hon. Chief Justice Samuel Wako Wambuzi who was the immediate successor of<br />Chief Justice Benedicto Kiwanuka; and who also presided over the Judiciary of Uganda for an aggregate period of over two decades; namely from 1971 to 1975, 1979 to 1980 and 1986 to 2001.</p><p>There is arguably no better person to speak with authority about the metamorphosis of the administration of justice in Uganda than Chief Justice Wambuzi who has had such an unequalled tenure at the helm of the Ugandan Judiciary; and who continues to demonstrate that the Ugandan Judiciary is his other home.</p><p>To the Judicial Officers and all the Justice service providers of this country, we must always take cognizance of the fact that Chief Justice Ben Kiwanuka has set the bar for the administration of justice very high for us.</p><p>Therefore, in the exercise of our mandate, we must always be driven by the need to respect and protect the rights of everyone, advance the rule of law, and promote the cause of justice in accordance with the oath we each took to “do right to all manner of people in accordance with the Constitution of the Republic of Uganda as by law established and in accordance with the laws and usage of the Republic of Uganda without fear or<br />favour, affection or ill will”; and at the end of which oath we beseeched the Lord God to help us live by that oath.</p><p>There is no denying that the cancer of corruption exists in the Judiciary.</p><p>But this is because the Judiciary is an integral part of our society, which has sadly been pervaded by this monster.</p><p>There is the endemic delay in rendering justice, and unacceptable conduct within the Judiciary in the<br />name of independence in the exercise of judicial function.</p><p>These negate the ideals for which Chief Justice Benedicto Kiwanuka paid with his life. Justice must never ever be for sale. It is monstrously repugnant to turn justice into a commodity; thereby according justice to the highest bidder.</p><p>The Judiciary administration has zero tolerance for the repugnant ill of corruption. But let me hasten to say this. The fight against real or perceived corruption in the Judiciary cannot be left to the Judiciary administration alone; and can never be successful when our society tolerates corruption or adores corrupt persons.</p><p>The fight against corruption is our individual and collective responsibility. Corruption is an abomination that must be confronted head on. We must all do what it takes to make corrupt practices a very unworthy enterprise.</p><p>We cannot claim to be honouring Benedicto Kiwanuka when cases take over 5 years in Court to dispose of; when litigants wait in vain and die of old age without seeing justice done, when our justice processes are<br />characterised by case backlog.</p><p>We cannot truly honour Benedicto Kiwanuka when our people still have to travel 200 Kms to find a high<br />Court service, or travel 70 Kms to find a Magistrate’s Court! We shall only truly render justice to our people when Court premises, like safe water, are within a walking distance from those who seek justice.</p><p>We can only truly serve justice to our people when a litigant can file a case on the 1st of January and get his judgement not later than 31st December of the same year. Namibia has done it. Malaysia has done it. We can<br />surely do it.</p><p>The magic lies in correlation of the number of judicial officers with the size of the population; and, in addition, the pursuit of technological innovations.</p><p>On the other hand, we continue to witness victims of torture and other abuse of human rights brought to Court. Cases of fabricated evidence that cannot stand in Court abound. Instances of refusal to respect<br />decisions of Courts are frequently reported.</p><p>All these unfortunate practices pour cold water on the memory of Benedicto Kiwanuka. It is on a day such as this when we honour the memory of our gallant judicial officer that we must each of us rededicate and recommit ourselves to ensure that this country enjoys the rule of law and democratic dispensation.</p><p>We can only honour our fallen Chief Justice when Court Orders are enforced timely, and respected by every person and authority in the land; and when torture, unlawful arrests and detentions, and ‘quid pro quo’ in exchange for justice is history.</p><p>We can only overcome the ills that afflict the Judiciary and our society at large when the Judiciary, the legislature and the executive are acting in concert with one voice to ensure that the much desired and pursued socio-economic transformation of our country takes place.</p><p>The Judiciary has taken strides towards removal of the impediments that have inhibited us from effective delivery of justice to our people.</p><p>We have embarked on a number of priorities including the implementation of the Judiciary Strategic Plan V, 2020/2021 to 2025/2026 which is hinged on the following Strategic Objectives:</p><p>a. To enhance equitable access to Judiciary Services;<br />b. To improve Court processes and case management;<br />c. To strengthen the use of ICT in the administration of justice;<br />d. To develop and support the Judiciary workforce and institutional capacity;<br />e. To improve coordination, partnerships and accountability;<br />f. To improve public awareness and the image of the Judiciary; and<br />g. To enhance resource mobilization and management. In the pursuit of this strategic plan, the Judiciary has received an unprecedented boost from the government.</p><p>This financial year 2021/2022, the Judiciary budget has seen a massive leap by being doubled from UGX 199bn/= where it had been stuck for years, to UGX 375bn/=. I seize the opportunity of this occasion to express our profound appreciation to Your Excellency for the stand you have taken and demonstrated to ensure that the Judiciary budget rises up; and with the undertaking that in the medium term it is destined to clock UGX 800bn/=.</p><p>This will provide the people of and in Uganda with a robust and effective Judiciary whose services are felt by the people.</p><p>The effect of this boost has already manifested itself in the targeted recruitment, this financial year, of a fairly sizeable number of judicial officers; namely 14 judges of the High Court, 32 Chief Magistrates, 142 Grade One Magistrates.</p><p>A corresponding number of support staff will also be recruited. Some of the areas that have not had judicial officers will do so this financial year.</p><p>We seek to strengthen coordination linkages between the Judiciary, and other Arms of Government, the Justice Law and Order institutions, Development Partners and all the other Justice providers.</p><p>Independence of the three arms of government does not mean a prohibition of these arms from working together.</p><p>A country can only achieve enduring peace, stability, and socio-economic development when the three arms of government operate in tandem with each other.</p><p>They each have functions clearly spelt out in the Constitution; and for effective government service, their functions are complementary to one another. They are each accorded oversight responsibility over each other to ensure full realisation of the peoples’ desires.</p><p>I once again extend my appreciation to all of you for turning up physically or by remote means, for the Memorial Lecture in honour of Chief Justice Benedicto Kiwanuka, to celebrate his laudable and memorable contributions to the administration of Justice and the rule of law in our country.</p><p>I wish to thank the Hon. the Deputy Chief Justice and the Organising Committee that he chaired, for the success of this day; given that we are operating against a backdrop of the menace of COVID-19 pandemic.</p><p><strong>May God Bless Us All.</strong><br /><strong>Alfonse Chigamoy Owiny – Dollo</strong><br /><strong>CHIEF JUSTICE</strong></p><div class="at-below-post addthis_tool" data-url="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/"></div> <div class="jeg_post_tags"><span>Tags:</span> <a href="https://nilepost.co.ug/tag/alfonse-owiny-dollo/" rel="tag">Alfonse Owiny-Dollo</a><a href="https://nilepost.co.ug/tag/benedicto-kiwanuka-memorial/" rel="tag">benedicto kiwanuka memorial</a></div> </div> </div> <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div class="jeg_postblock_2 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_119226_0_617639cac4e93 " data-unique="jnews_module_119226_0_617639cac4e93"> <div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3> </div> <div class="jeg_block_container"> <article class="jeg_post jeg_pl_lg_2 post-112832 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-adjumani tag-alfonse-owiny-dollo tag-amuru tag-apaa-land tag-museveni tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict/"><div class="thumbnail-container animate-lazy size-715 "></div></a> <div class="jeg_post_category"> <span><a href="https://nilepost.co.ug/category/news/" class="category-news">News</a></span> </div> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict/">Museveni to set up commission of inquiry into Apaa land conflict</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict/"><i class="fa fa-clock-o"></i> August 13, 2021</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div> <div class="jeg_post_excerpt"> <p>President Museveni has said he is to set up a commission of inquiry over the disputed Apaa land located on...</p> <a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict/" class="jeg_readmore">Read more</a> </div> </div> </article> <div class="jeg_posts_wrap"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_sm post-114858 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-adjumani tag-alfonse-owiny-dollo tag-amuru tag-apaa-land tag-museveni tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict-2/"> <div class="thumbnail-container animate-lazy size-715 "></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict-2/">Museveni to set up commission of inquiry into Apaa land conflict</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/08/13/museveni-to-set-up-commission-of-inquiry-into-apaa-land-conflict-2/"><i class="fa fa-clock-o"></i> August 13, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-112021 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-alfonse-owiny-dollo tag-election-petition tag-jameson-karemani tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month/"> <div class="thumbnail-container animate-lazy size-715 "></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month/">Chief Justice issues guidelines on hearing election petitions starting this month</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month/"><i class="fa fa-clock-o"></i> August 4, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-114722 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-alfonse-owiny-dollo tag-election-petition tag-jameson-karemani tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month-2/"> <div class="thumbnail-container animate-lazy size-715 "></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month-2/">Chief Justice issues guidelines on hearing election petitions starting this month</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/08/04/chief-justice-issues-guidelines-on-hearing-election-petitions-starting-this-month-2/"><i class="fa fa-clock-o"></i> August 4, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-110863 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-alfonse-owiny-dollo tag-chief-justice tag-judiciary tag-supreme-court tag-uganda tag-ugandan-news tag-ujoa"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/07/22/supreme-court-to-expand-wings-upcountry-in-new-judiciary-structure/"> <div class="thumbnail-container animate-lazy size-715 "></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/07/22/supreme-court-to-expand-wings-upcountry-in-new-judiciary-structure/">Supreme Court to expand wings upcountry in new judiciary structure</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/07/22/supreme-court-to-expand-wings-upcountry-in-new-judiciary-structure/"><i class="fa fa-clock-o"></i> July 22, 2021</a></div></div> </div> </article> </div> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_119226_0_617639cac4e93 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":119226,"include_category":"","exclude_category":"","include_author":"","include_tag":"83970,107341","exclude_tag":"","job_listing_type":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_2"};</script> </div></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"><div id="comments" class="comment-wrapper section" data-type="facebook" data-id="1950641841925118"><h3 class='comment-heading'>Discussion about this post</h3><div class="fb-comments" data-href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/" data-num-posts="10" data-width="100%"></div></div></div> </div> </div> <div class="jeg_sidebar left jeg_sticky_sidebar col-md-3"> <div class="widget widget_jnews_social_counter" id="jnews_social_counter-8"><div class="jeg_block_heading jeg_block_heading_6 jnews_617639caca254"><h3 class="jeg_block_title"><span>Follow Us</span></h3></div><ul class="jeg_socialcounter col1 light"> <li class="jeg_facebook"> <a href="https://www.facebook.com/nilepostnews"><i class="fa fa-facebook"></i> <span>185.9k</span> <small>Fans</small> </a> </li><li class="jeg_twitter"> <a href="https://twitter.com/nilepostnews"><i class="fa fa-twitter"></i> <span>229k</span> <small>Followers</small> </a> </li> </ul></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-20"><div class='jeg_ad jeg_ad_module jnews_module_119226_1_617639cc61660 '><div class='ads-wrapper'></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-16"><div class='jeg_ad jeg_ad_module jnews_module_119226_2_617639cc617bf '><div class='ads-wrapper'></div></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-5"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_119226_3_617639cc61c6d jeg_pb_boxed normal " data-unique="jnews_module_119226_3_617639cc61c6d"> <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Latest</span></h3> </div> <div class="jeg_block_container"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_sm post-119230 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-islamic-state tag-komamboga"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="57" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="62-year old nurse shot dead in Namisindwa" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2017/11/crime.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2017/11/crime.jpg 1140w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-300x142.jpg 300w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-768x364.jpg 768w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-1024x485.jpg 1024w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-800x379.jpg 800w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-600x284.jpg 600w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/">Islamic State: &#8216;We are behind bomb attack in Komamboga&#8217;</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/"><i class="fa fa-clock-o"></i> October 25, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-119226 post type-post status-publish format-standard has-post-thumbnail hentry category-opinions tag-alfonse-owiny-dollo tag-benedicto-kiwanuka-memorial"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-120x86.jpeg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-120x86.jpeg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/Owiny-Dollo-350x250.jpeg 350w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/">Owiny Dollo&#8217;s full speech at the fourth Benedcito Kiwanuka Memorial</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/25/owiny-dollos-full-speech-at-the-fourth-benedcito-kiwanuka-memorial/"><i class="fa fa-clock-o"></i> October 25, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-119224 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-fred-enanga tag-komamboga tag-museveni tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="The perpetuators will be got, says Museveni after Komamboga bomb blast" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-350x250.jpg 350w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/">The parasitic pigs have foolishly invited us to crush them, says Museveni on Komamboga attack</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/"><i class="fa fa-clock-o"></i> October 24, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-119218 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-adf tag-fred-enanga tag-museveni tag-police tag-uganda"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Police: How Komamboga bomb attack was orchestrated" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-750x536.jpg 750w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/">Police says Komamboga bomb attack was an act of domestic terror</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/"><i class="fa fa-clock-o"></i> October 24, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-119215 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-fred-enanga tag-komamboga tag-police tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/24/police-how-komamboga-bomb-attack-was-orchestrated/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Police: How Komamboga bomb attack was orchestrated" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-750x536.jpg 750w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/24/police-how-komamboga-bomb-attack-was-orchestrated/">Police: How Komamboga bomb attack was orchestrated</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/24/police-how-komamboga-bomb-attack-was-orchestrated/"><i class="fa fa-clock-o"></i> October 24, 2021</a></div></div> </div> </article> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_119226_3_617639cc61c6d = {"header_icon":"","first_title":"Latest","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"","post_type":"post","content_type":"all","number_post":"5","post_offset":"","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","job_listing_type":"","sort_by":"latest","date_format":"default","date_format_custom":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"1","pagination_scroll_limit":"","boxed":"1","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script> </div></div></div><div class="jeg_sidebar right jeg_sticky_sidebar col-md-3"> <div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-13"><div class='jeg_ad jeg_ad_module jnews_module_119226_4_617639cc79707 '><div class='ads-wrapper'><a href='https://link.safeboda.com/cocacola' target='_blank' class='adlink ads_image '><img src='https://nilepost.co.ug/wp-content/uploads/2020/11/cocacola-ad-safeboda.gif' alt='cocacola-ad-safeboda' data-pin-no-hover="true"></a><a href='https://link.safeboda.com/cocacola' target='_blank' class='adlink ads_image_tablet '><img src='https://nilepost.co.ug/wp-content/uploads/2020/11/cocacola-ad-safeboda.gif' alt='cocacola-ad-safeboda' data-pin-no-hover="true"></a><a href='https://link.safeboda.com/cocacola' target='_blank' class='adlink ads_image_phone '><img src='https://nilepost.co.ug/wp-content/uploads/2020/11/cocacola-ad-safeboda.gif' alt='cocacola-ad-safeboda' data-pin-no-hover="true"></a></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-10"><div class='jeg_ad jeg_ad_module jnews_module_119226_5_617639cc79c62 '><div class='ads-wrapper'></div></div></div><div class="widget widget_jnews_module_block_17" id="jnews_module_block_17-1"><div class="jeg_postblock_17 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_119226_6_617639cc7a399 jeg_pb_boxed normal " data-unique="jnews_module_119226_6_617639cc7a399"> <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Featured</span></h3> </div> <div class="jeg_block_container"> <div class="jeg_posts_wrap"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_md_1 post-119230 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-islamic-state tag-komamboga"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/"><div class="thumbnail-container animate-lazy size-500 "><img width="360" height="171" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="62-year old nurse shot dead in Namisindwa" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2017/11/crime.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2017/11/crime.jpg 1140w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-300x142.jpg 300w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-768x364.jpg 768w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-1024x485.jpg 1024w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-800x379.jpg 800w, https://nilepost.co.ug/wp-content/uploads/2017/11/crime-600x284.jpg 600w" data-expand="700" /></div></a> <div class="jeg_post_category"> <span><a href="https://nilepost.co.ug/category/news/featured/" class="category-featured">Featured</a></span> </div> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/">Islamic State: &#8216;We are behind bomb attack in Komamboga&#8217;</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/admin/">NP admin</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/"><i class="fa fa-clock-o"></i> October 25, 2021</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2021/10/25/islamic-state-we-are-behind-bomb-attack-in-komamboga/#comments"><i class="fa fa-comment-o"></i> 0 </a></div></div> <div class="jeg_post_excerpt"> <p>Islamic state claimed responsibility for a bomb attack...</p> </div> </div> </article> <article class="jeg_post jeg_pl_sm post-119224 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-fred-enanga tag-komamboga tag-museveni tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="The perpetuators will be got, says Museveni after Komamboga bomb blast" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/E3i3fhuXMAcfv1h-350x250.jpg 350w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/">The parasitic pigs have foolishly invited us to crush them, says Museveni on Komamboga attack</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/24/the-parasitic-pigs-have-foolishly-invited-us-to-crush-them-says-museveni-on-komamboga-attack/"><i class="fa fa-clock-o"></i> October 24, 2021</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-119218 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-adf tag-fred-enanga tag-museveni tag-police tag-uganda"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Police: How Komamboga bomb attack was orchestrated" loading="lazy" data-src="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2021/10/enanga-750x536.jpg 750w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/">Police says Komamboga bomb attack was an act of domestic terror</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2021/10/24/police-says-komamboga-bomb-attack-was-an-act-of-domestic-terror/"><i class="fa fa-clock-o"></i> October 24, 2021</a></div></div> </div> </article> </div> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_119226_6_617639cc7a399 = {"header_icon":"","first_title":"Featured","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"95","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","job_listing_type":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"8","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"1","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_17"};</script> </div></div></div> </div> <div class="jeg_ad jeg_article jnews_article_bottom_ads"> <div class='ads-wrapper '></div> </div> </div></div> </div> </div> <div id="post-body-class" class="post-template-default single single-post postid-119226 single-format-standard wp-megamenu jeg_single_tpl_1 jnews jeg_boxed jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div> </div> <div class="post-ajax-overlay"> <div class="preloader_type preloader_circle"> <div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="newsfeed_preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="newsfeed_preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div></div> </div> <div class="footer-holder" id="footer" data-id="footer"> <div class="jeg_footer jeg_footer_4 normal"> <div class="jeg_footer_container jeg_container"> <div class="jeg_footer_content"> <div class="container"> <div class="row"> <div class="jeg_footer_primary clearfix"> <div class="col-md-9 footer_column"> <ul class="jeg_menu_footer"><li id="menu-item-33411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33411"><a href="#">About</a></li><li id="menu-item-33412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33412"><a href="#">Advertise</a></li><li id="menu-item-33413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33413"><a href="https://nilepost.co.ug/jobs/">Careers</a></li></ul> </div> <div class="col-md-3 footer_column footer_right"> <div class="footer-text"> <strong> Call us: +256-417-720-101 </div> </div> </div> <div class="jeg_footer_secondary clearfix"> <div class="col-md-9 footer_column"> <p class="copyright"> © 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company. </p> </div> <div class="col-md-3 footer_column footer_right"> <div class="jeg_social_icon_block socials_widget nobg"> <a href="https://www.facebook.com/nilepostnews" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div> </div> </div> </div> </div> </div> </div></div> </div> <div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a> </div> </div> <div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a> <div class="jeg_bg_overlay"></div> <div class="jeg_mobile_wrapper"> <div class="nav_wrap"> <div class="item_main"> <div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Results Found </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Results </div></div></div><div class="jeg_aside_item"> <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765"><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-70154"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/">2021 Elections Watch</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70159"><a href="https://nilepost.co.ug/category/news/2021-elections-watch/the-election-podcast/">The Election Podcast</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492"><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668"><a href="https://nilepost.co.ug/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-768"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70006"><a href="https://nilepost.co.ug/category/opinions/columns/parting-shot/">Parting Shot</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">Week in Ugandan News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116682"><a href="https://nilepost.co.ug/category/mable-twegumye-zake-bits-of-me/">Mable Twegumye Zake&#8217;s #BitsOfMe&amp;You</a></li></ul></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629"><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497"><a href="#">Lifestyle</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232"><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33498"><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70763"><a href="https://nilepost.co.ug/category/lifestyle/health-2/coronavirus-outbreak/">Coronavirus outbreak</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500"><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &amp; Travel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499"><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868"><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344"><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727"><a href="#">Special Reports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600"><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633"><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495"><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632"><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496"><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76426"><a href="https://nilepost.co.ug/jobs/">Jobs</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507"><a href="https://nilepost.co.ug/category/live/">Archives</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-77189"><a href="https://nilepost.co.ug/live-updates/">Live</a></li></ul></div> </div> <div class="item_bottom"> <div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/nilepostnews" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company.</p></div> </div></div> </div></div><script type="text/javascript">var jfla = []</script><div class="jeg_read_progress_wrapper"></div><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"nilepostnews"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-9dbb186ab1403bebe3dbdb90cd27b689","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; }(function() {var first_load_interval_id = setInterval(function () {if (typeof window.addthis !== 'undefined') {window.clearInterval(first_load_interval_id);if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {window.addthis.layers(window.addthis_layers);}if (Array.isArray(window.addthis_layers_tools)) {for (i = 0; i < window.addthis_layers_tools.length; i++) {window.addthis.layers(window.addthis_layers_tools[i]);}}}},1000)
}());</script><noscript id="deferred-styles"><link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Roboto%3Areguler%7CRoboto+Condensed%3A700%2Cregular%2Cregular%2C700%7CPT+Serif%3Aregular%2Citalic%2C700%2C700italic&#038;ver=1.0.0' type='text/css' media='all' /><!--[if lt IE 9]><link rel='stylesheet' id='vc_lte_ie9-css' href='https://nilepost.co.ug/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' /><![endif]--><link rel='stylesheet' id='poppins-css' href='//fonts.googleapis.com/css?family=Poppins%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;ver=1.4.1' type='text/css' media='all' /><link rel='stylesheet' id='minit-css-css' href='https://nilepost.co.ug/wp-content/uploads/minit/756d9a33.css' type='text/css' media='all' /></noscript><script>var loadDeferredStyles = function() {var addStylesNode = document.getElementById("deferred-styles");var replacement = document.createElement("div");replacement.innerHTML = addStylesNode.textContent;document.body.appendChild(replacement)
addStylesNode.parentElement.removeChild(addStylesNode);};var raf = requestAnimationFrame || mozRequestAnimationFrame ||
webkitRequestAnimationFrame || msRequestAnimationFrame;if (raf) raf(function() { window.setTimeout(loadDeferredStyles, 0); });else window.addEventListener('load', loadDeferredStyles);</script><!--[if lt IE 9]><script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=5.1.0' id='html5shiv-js'></script><![endif]--><script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.7.3#pubid=ra-59ff2f54dd4ccb30' id='addthis_widget-js'></script><script type='text/javascript' id='minit-js-js-extra'>
var pvcArgsFrontend = {"mode":"js","requestURL":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","postID":"119226","nonce":"b2975dd124"};var ajax_objects = {"ajaxurl":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","redirecturl":"https:\/\/nilepost.co.ug\/","loadingmessage":"Sending user info, please wait..."};var wpmm_object = {"ajax_url":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","wpmm_responsive_breakpoint":"767px","wpmm_disable_mobile":"false"};var postgrid_ajax_load = {"ajax_url":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","redirecturl":"https:\/\/nilepost.co.ug\/"};var pp_ajax_form = {"ajaxurl":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"e105baa765","disable_ajax_form":"false"};var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"119226","isblog":"1","admin_bar":"0","follow_video":"1","follow_position":"top_right","rtl":"0","gif":"","site_slug":"\/","site_domain":"nilepost.co.ug"};
</script><script async type='text/javascript' src='https://nilepost.co.ug/wp-content/uploads/minit/b9842a5.js' id='minit-js-js'></script><script id="minit-async-scripts" type="text/javascript">(function() {var js, fjs = document.getElementById('minit-async-scripts'),add = function( url, id ) {js = document.createElement('script');js.type = 'text/javascript';js.src = url;js.async = true;js.id = id;fjs.parentNode.insertBefore(js, fjs);};add( "", "async-script-jquery" ); add( "https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-59ff2f54dd4ccb30", "async-script-addthis_widget" ); })();
</script><div class="jeg_ad jnews_mobile_sticky_ads "></div><style type="text/css" id="wp-custom-css">.nivo-caption{background:transparent !important;position:absolute;color:transparent !important;-moz-opacity:.8}</style></body></html>