<!doctype html><!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"> <![endif]--><!--[if IE 7]> <html class="no-js lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"> <![endif]--><!--[if IE 8]> <html class="no-js lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"> <![endif]--><!--[if IE 9]> <html class="no-js lt-ie10" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"> <![endif]--><!--[if gt IE 8]><!--> <html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"> <!--<![endif]--><head> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://nilepost.co.ug/xmlrpc.php" /> <title>Judiciary is not a mere department under justice ministry but autonomous - court rules - Nile Post</title> <script type="text/javascript"> var jnews_ajax_url = 'https://nilepost.co.ug/?ajax-request=jnews'; </script> <meta name="description" content="Nile Post - Judiciary is not a mere department under justice ministry but autonomous - court rules News"/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Feed" href="https://nilepost.co.ug/feed/" /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Comments Feed" href="https://nilepost.co.ug/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Nile Post &raquo; Judiciary is not a mere department under justice ministry but autonomous &#8211; court rules Comments Feed" href="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/feed/" /><script type="text/javascript" data-cfasync="false">var mi_version         = '7.10.2';var mi_track_user      = true;var mi_no_track_reason = '';var disableStr = 'ga-disable-UA-143751353-1';
function __gaTrackerIsOptedOut() {return document.cookie.indexOf(disableStr + '=true') > -1;}
if ( __gaTrackerIsOptedOut() ) {window[disableStr] = true;}
function __gaTrackerOptout() {document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';window[disableStr] = true;}if ( mi_track_user ) {(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
__gaTracker('create', 'UA-143751353-1', 'auto');__gaTracker('set', 'forceSSL', true);__gaTracker('require', 'displayfeatures');__gaTracker('send','pageview');} else {console.log( "" );(function() {
var noopfn = function() {return null;};var noopnullfn = function() {return null;};var Tracker = function() {return null;};var p = Tracker.prototype;p.get = noopfn;p.set = noopfn;p.send = noopfn;var __gaTracker = function() {var len = arguments.length;if ( len === 0 ) {return;}var f = arguments[len-1];if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );return;}try {f.hitCallback();} catch (ex) {}};__gaTracker.create = function() {return new Tracker();};__gaTracker.getByName = noopnullfn;__gaTracker.getAll = function() {return [];};__gaTracker.remove = noopfn;window['__gaTracker'] = __gaTracker;})();}</script><link rel='https://api.w.org/' href='https://nilepost.co.ug/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nilepost.co.ug/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nilepost.co.ug/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 5.2.5" /><link rel="alternate" type="application/json+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2020%2F03%2F12%2Fjudiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules%2F" /><link rel="alternate" type="text/xml+oembed" href="https://nilepost.co.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnilepost.co.ug%2F2020%2F03%2F12%2Fjudiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules%2F&#038;format=xml" /> <style media="screen">.simplesocialbuttons.simplesocialbuttons_inline .ssb-fb-like{margin:}.simplesocialbuttons.simplesocialbuttons_inline.simplesocial-round-icon button{margin:}</style><style type="text/css"></style><style>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</style><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO Core 6.16.1/S"/><meta name="generator" content="WPSSO PLM 4.4.2/S"/><link rel="shortlink" href="https://nilepost.co.ug/?p=69626"/><meta property="fb:app_id" content="439719129917017"/><meta property="og:type" content="article"/><meta property="og:url" content="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Nile Post"/><meta property="og:title" content="Judiciary is not a mere department under justice ministry but..."/><meta property="og:description" content="The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government. In 2018, lawyers under their professional body, the Uganda Law Society (ULS), have sued government for failure to provide an..."/><meta property="og:updated_time" content="2020-03-12T07:25:12+00:00"/><meta property="og:image" content="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-600x315-cropped.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:publisher" content="https://web.facebook.com/nilepostnews"/><meta property="article:published_time" content="2020-03-12T07:23:41+00:00"/><meta property="article:modified_time" content="2020-03-12T07:25:12+00:00"/><meta property="article:section" content="News (General)"/><meta property="article:tag" content="Cheborion Barishaki"/><meta property="article:tag" content="Constitutional court"/><meta property="article:tag" content="judiciary"/><meta property="article:tag" content="kenneth kakuru"/><meta property="article:tag" content="uganda"/><meta property="article:tag" content="Uganda Law Society"/><meta property="article:tag" content="Ugandan News"/><meta name="weibo:article:create_at" content="2020-03-12 07:23:41"/><meta name="weibo:article:update_at" content="2020-03-12 07:25:12"/><meta name="twitter:domain" content="nilepost.co.ug"/><meta name="twitter:site" content="@nilepostnews"/><meta name="twitter:title" content="Judiciary is not a mere department under justice ministry but..."/><meta name="twitter:description" content="The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government. In 2018, lawyers under their..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-600x329.jpg?5e69e3d958ee5"/><link itemprop="url" href="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/"/><meta itemprop="name" content="Judiciary is not a mere department under justice ministry but..."/><meta itemprop="description" content="The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government. In 2018, lawyers under their professional body, the Uganda Law Society (ULS)..."/><meta itemprop="datePublished" content="2020-03-12T07:23:41+00:00"/><meta itemprop="dateModified" content="2020-03-12T07:25:12+00:00"/><link itemprop="thumbnailurl" href="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-600x315-cropped.jpg"/><meta name="author" content="Kenneth Kazibwe"/><meta name="thumbnail" content="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-600x315-cropped.jpg"/><meta name="wpsso:mark:end" content="wpsso meta tags end"/><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><meta name="generator" content="Powered by Slider Revolution 6.0.7 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." /><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/nilepost.co.ug\/#organization","url":"https:\/\/nilepost.co.ug\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/nilepostnews","https:\/\/twitter.com\/nilepostnews","http:\/\/nilepost.co.ug\/feed"]}</script><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/nilepost.co.ug\/#website","url":"https:\/\/nilepost.co.ug\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/nilepost.co.ug\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script><link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy-75x75.png" sizes="32x32" /><link rel="icon" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" /><meta name="msapplication-TileImage" content="https://nilepost.co.ug/wp-content/uploads/2019/07/NilePost-Logo-copy.png" /><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display:none}</style><script type="text/javascript">function setREVStartSize(a){try{var b,c=document.getElementById(a.c).parentNode.offsetWidth;if(c=0===c||isNaN(c)?window.innerWidth:c,a.tabw=void 0===a.tabw?0:parseInt(a.tabw),a.thumbw=void 0===a.thumbw?0:parseInt(a.thumbw),a.tabh=void 0===a.tabh?0:parseInt(a.tabh),a.thumbh=void 0===a.thumbh?0:parseInt(a.thumbh),a.tabhide=void 0===a.tabhide?0:parseInt(a.tabhide),a.thumbhide=void 0===a.thumbhide?0:parseInt(a.thumbhide),a.mh=void 0===a.mh||""==a.mh?0:a.mh,"fullscreen"===a.layout||"fullscreen"===a.l)b=Math.max(a.mh,window.innerHeight);else{for(var d in a.gw=Array.isArray(a.gw)?a.gw:[a.gw],a.rl)(void 0===a.gw[d]||0===a.gw[d])&&(a.gw[d]=a.gw[d-1]);for(var d in a.gh=void 0===a.el||""===a.el||Array.isArray(a.el)&&0==a.el.length?a.gh:a.el,a.gh=Array.isArray(a.gh)?a.gh:[a.gh],a.rl)(void 0===a.gh[d]||0===a.gh[d])&&(a.gh[d]=a.gh[d-1]);var e,f=Array(a.rl.length),g=0;for(var d in a.tabw=a.tabhide>=c?0:a.tabw,a.thumbw=a.thumbhide>=c?0:a.thumbw,a.tabh=a.tabhide>=c?0:a.tabh,a.thumbh=a.thumbhide>=c?0:a.thumbh,a.rl)f[d]=a.rl[d]<window.innerWidth?0:a.rl[d];for(var d in e=f[0],f)e>f[d]&&0<f[d]&&(e=f[d],g=d);var h=c>a.gw[g]+a.tabw+a.thumbw?1:(c-(a.tabw+a.thumbw))/a.gw[g];b=a.gh[g]*h+(a.tabh+a.thumbh)}void 0===window.rs_init_css&&(window.rs_init_css=document.head.appendChild(document.createElement("style"))),document.getElementById(a.c).height=b,window.rs_init_css.innerHTML+="#"+a.c+"_wrapper { height: "+b+"px }"}catch(a){console.log("Failure at Presize of Slider:"+a)}};</script><noscript><style> .wpb_animate_when_almost_visible{opacity:1}</style></noscript></head><body class="post-template-default single single-post postid-69626 single-format-standard wp-megamenu jeg_single_tpl_1 jnews jeg_boxed jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"> <div class="jeg_ad jeg_ad_top jnews_header_top_ads"> <div class='ads-wrapper '></div> </div>  <div class="jeg_viewport"> <div class="jeg_header_wrapper"> <div class="jeg_header_instagram_wrapper"> </div><div class="jeg_header full"> <div class="jeg_midbar jeg_container normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title"> <a href="https://nilepost.co.ug/" style="padding: 0px 0px 0px 0px;"> <img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" alt="Nile Post"data-light-src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" data-dark-src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x"> </a> </div></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads"> <div class='ads-wrapper '></div></div> </div> </div> </div> </div></div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_nav_icon"> <a href="#" class="toggle_btn jeg_mobile_toggle"> <span></span><span></span><span></span> </a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-765" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-765 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li id="menu-item-14258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li id="menu-item-33490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li id="menu-item-33491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li id="menu-item-33492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li id="menu-item-33668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/business/">Business</a></li><li id="menu-item-768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li id="menu-item-34124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li id="menu-item-34125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li id="menu-item-34126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34126 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/unconventional-thought/">Unconventional Thought</a></li><li id="menu-item-53331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li id="menu-item-55490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">This Week in Ugandan News</a></li></ul></li></ul></li><li id="menu-item-14629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li id="menu-item-14628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li id="menu-item-33864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li id="menu-item-33866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li id="menu-item-33865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li id="menu-item-33867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li id="menu-item-796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li id="menu-item-798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li id="menu-item-800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li id="menu-item-799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li id="menu-item-33497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497 bgnav" data-item-row="default" ><a href="#">Lifestyle</a><ul class="sub-menu"><li id="menu-item-55232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li id="menu-item-33498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33498 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a></li><li id="menu-item-33500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &#038; Travel</a></li><li id="menu-item-33499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li id="menu-item-33868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li id="menu-item-3344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li id="menu-item-3727" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727 bgnav" data-item-row="default" ><a href="#">Special Reports</a><ul class="sub-menu"><li id="menu-item-33486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li id="menu-item-33485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li id="menu-item-33487" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li id="menu-item-33489" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li id="menu-item-33501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li id="menu-item-2706" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li id="menu-item-33488" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li id="menu-item-17600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-14633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li id="menu-item-33495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li id="menu-item-14632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li id="menu-item-33496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li id="menu-item-33507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/live/"><i class='jeg_font_menu fa fa-video-camera'></i>Live</a></li></ul></div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Result </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result </div></div></div> </div> </div> </div> </div></div></div> </div> <div class="jeg_header_sticky"> <div class="sticky_blankspace"></div><div class="jeg_header full"> <div class="jeg_container"> <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_grow"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item jeg_nav_icon"> <a href="#" class="toggle_btn jeg_mobile_toggle"> <span></span><span></span><span></span> </a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_normal"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-765 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34126 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/unconventional-thought/">Unconventional Thought</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">This Week in Ugandan News</a></li></ul></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497 bgnav" data-item-row="default" ><a href="#">Lifestyle</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33498 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &#038; Travel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727 bgnav" data-item-row="default" ><a href="#">Special Reports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507 bgnav" data-item-row="default" ><a href="https://nilepost.co.ug/category/live/"><i class='jeg_font_menu fa fa-video-camera'></i>Live</a></li></ul></div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_grow"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Result </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result </div></div></div> </div> </div> </div></div> </div> </div></div> </div> <div class="jeg_navbar_mobile_wrapper"> <div class="jeg_navbar_mobile" data-mode="scroll"> <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal"> <div class="container"> <div class="jeg_nav_row"> <div class="jeg_nav_col jeg_nav_left jeg_nav_normal"> <div class="item_wrap jeg_nav_alignleft"> <div class="jeg_nav_item"> <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div> </div> </div> <div class="jeg_nav_col jeg_nav_center jeg_nav_grow"> <div class="item_wrap jeg_nav_aligncenter"> <div class="jeg_nav_item jeg_mobile_logo"><div class="site-title"> <a href="https://nilepost.co.ug/"> <img class='jeg_logo_img' src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" alt="Nile Post"data-light-src="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png" data-light-srcset="https://nilepost.co.ug/wp-content/uploads/2018/12/NP-200X64-logo-big.png 1x, https://nilepost.co.ug/wp-content/uploads/2018/12/NilePost-Logo-300x87.png 2x" data-dark-src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://nilepost.co.ug/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x"> </a> </div></div> </div> </div> <div class="jeg_nav_col jeg_nav_right jeg_nav_normal"> <div class="item_wrap jeg_nav_alignright"> <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Result </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result </div></div></div> </div> </div> </div> </div></div></div><div class="sticky_blankspace" style="height: 60px;"></div> </div> <div class="post-wrapper"> <div class="post-wrap" > <div class="jeg_main jeg_double_sidebar"> <div class="jeg_container"> <div class="jeg_content jeg_singlepage"> <div class="container"> <div class="jeg_ad jeg_article jnews_article_top_ads"> <div class='ads-wrapper '></div> </div> <div class="row"> <div class="jeg_main_content col-md-6"> <div class="jeg_inner_content"> <div class="entry-header"> <h1 class="jeg_post_title">Judiciary is not a mere department under justice ministry but autonomous &#8211; court rules</h1> <h2 class="jeg_post_subtitle">The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government.</h2> <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1"> <div class="meta_left"> <div class="jeg_meta_author"> <img src="https://nilepost.co.ug/wp-content/uploads/2018/06/IMG_8522-2-100x100.jpg" width="80" height="80" alt="Kenneth Kazibwe" class="avatar avatar-80 wp-user-avatar wp-user-avatar-80 alignnone photo" nopin="nopin" /> <span class="meta_text">by</span> <a href="https://nilepost.co.ug/author/kenny/">Kenneth Kazibwe</a> </div> <div class="jeg_meta_date"> <a href="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/">3 hours ago</a> </div> <div class="jeg_meta_category"> <span><span class="meta_text">in</span> <a href="https://nilepost.co.ug/category/news/" rel="category tag">News</a> </span> </div> </div> <div class="meta_right"> </div></div></div> </div> <div class="jeg_featured featured_image"><a href="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:54.839%"><img width="620" height="340" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-750x375 size-jnews-750x375 lazyload wp-post-image" alt="Muwema: How judges in Uganda have lost their judicial immunity" data-wp-pid="20254" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2018/07/Judges.jpg 620w, https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-300x165.jpg 300w, https://nilepost.co.ug/wp-content/uploads/2018/07/Judges-600x329.jpg 600w" data-expand="700" /></div></a></div> <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper '></div></div> <div class="entry-content no-share"> <div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome"> </div> <div class="content-inner "> <div class="wpsso-schema-image-for-pinterest" style="display:none;"></div><p><strong>The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government.</strong></p><p>In 2018, lawyers under their professional body, the Uganda Law Society (ULS), have sued government for failure to provide an enabling environment to the Judiciary to have its own self-accounting status like other two arms of government.</p><p>The lawyers argued that the independence of the judiciary is provided for under Article 128 (1) of the Constitution demands that in exercise of their judicial power, courts shall not be subject to the control of any person or authority.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads "><div class='ads-wrapper align-right '><a href="https://bit.ly/ASPNilePost" target="_blank" class='adlink ads_image align-right'><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/250-250PX.png' alt='Airtel Uganda Ad' data-pin-no-hover="true"></a><a href="https://bit.ly/ASPNilePost" target="_blank" class='adlink ads_image_tablet align-right'><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/250-250PX.png' alt='Airtel Uganda Ad' data-pin-no-hover="true"></a><a href="https://bit.ly/ASPNilePost" target="_blank" class='adlink ads_image_phone align-right'><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/728-90PX.gif' alt='Airtel Uganda Ad' data-pin-no-hover="true"></a></div></div><p>On Wednesday, a panel of five justices including Kenneth Kakuru, Geoffrey Kiryabwire, Cheborion Barishaki, Ezekiel Muhanguzi and Stephen Musota ruled that it was a contravention of the Constitution for government not to implement the autonomous status of the judiciary.</p><p>“The failure by the executive and parliament to take steps in a reasonable time to enact a law to implement the judiciary’s autonomy contravenes articles 8A and National Objective and Directive Principles of State Policy VIII and Article 128(3) of the 1995 Constitution,” said Justice Barishaki who wrote the lead judgment.</p><p>Quoting the Public Finance Management Act, 2015, Uganda Law Society told court in its petition that it is wrong for the Secretary to the Treasury to have powers to the effect that he issues directives to all accounting officers but includes the self-accounting institutions like the judiciary in the same category.</p><p>In their judgment, the justices of the Constitutional court reasoned with the lawyers’ body saying the practice is illegal since it undermines the judiciary’s independence.</p><p>In the petition, the lawyers’ body told court that it is unconstitutional for the Justice Minister to annually approve the budgetary framework of the judiciary yet it is an independent arm of government.</p><p>The court reasoned with the petitioners saying it is wrong for government to take the judiciary as a mere department under the Ministry of Justice during the budgetary process.</p><p>“The judiciary as an arm of government is supposed to take control of its budgetary processes without any interference from the executive. The executive’s role is to forward the judiciary’s budgetary estimates to parliament for consideration,” the judges ruled.</p><p>The court also ruled that the role of Permanent Secretary ought not to have extended to the judiciary since the Chief Justice is the accounting officer of the third arm of government.</p><p>The judges said that the Permanent Secretary ought to report to the Chief Justice and not to the executive arm of government as is the case currently.</p><p>“The allocation of inadequate resources to the judiciary is inconsistent with and in contravention of the Constitution,” the Constitutional Court ruled.</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><div class="simplesocialbuttons simplesocial-round-icon simplesocialbuttons_inline simplesocialbuttons-align-left post-69626 post simplesocialbuttons-inline-no-animation"><button class="simplesocial-fb-share" target="_blank" data-href="https://www.facebook.com/sharer/sharer.php?u=https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Facebook </span> </button><button class="simplesocial-twt-share" data-href="https://twitter.com/share?text=Judiciary+is+not+a+mere+department+under+justice+ministry+but++autonomous+%E2%80%93+court+rules&url=https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/&via=nilepostnews @nbstv #NilePostNews #NBSUpdates" rel="nofollow" onclick="javascript:window.open(this.dataset.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><span class="simplesocialtxt">Twitter</span> </button><button onclick="javascript:window.open(this.dataset.href, '_blank' );return false;" class="simplesocial-whatsapp-share" data-href="https://web.whatsapp.com/send?text=https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/"><span class="simplesocialtxt">WhatsApp</span></button></div> <div class="jeg_post_tags"><span>Tags:</span> <a href="https://nilepost.co.ug/tag/cheborion-barishaki/" rel="tag">Cheborion Barishaki</a><a href="https://nilepost.co.ug/tag/constitutional-court/" rel="tag">Constitutional court</a><a href="https://nilepost.co.ug/tag/judiciary/" rel="tag">judiciary</a><a href="https://nilepost.co.ug/tag/kenneth-kakuru/" rel="tag">kenneth kakuru</a><a href="https://nilepost.co.ug/tag/uganda/" rel="tag">uganda</a><a href="https://nilepost.co.ug/tag/uganda-law-society/" rel="tag">Uganda Law Society</a><a href="https://nilepost.co.ug/tag/ugandan-news/" rel="tag">Ugandan News</a></div> </div> </div> <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper '><a href="https://bit.ly/ASPNilePost" class='adlink ads_image '><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/728-90PX.gif' alt='' data-pin-no-hover="true"></a><a href="https://bit.ly/ASPNilePost" class='adlink ads_image_tablet '><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/728-90PX.gif' alt='' data-pin-no-hover="true"></a><a href="https://bit.ly/ASPNilePost" class='adlink ads_image_phone '><img src='https://nilepost.co.ug/wp-content/uploads/2020/01/728-90PX.gif' alt='' data-pin-no-hover="true"></a></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div class="jeg_postblock_2 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_69626_0_5e6a0a9d85915 " data-unique="jnews_module_69626_0_5e6a0a9d85915"> <div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3> </div> <div class="jeg_block_container"> <article class="jeg_post jeg_pl_lg_2 post-69640 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-lifestyle tag-deported tag-uganda tag-ugandanews tag-visa tag-yvonne-chaka-chaka"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/"><div class="thumbnail-container animate-lazy size-715 "><img width="350" height="250" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="I am coming back to Uganda to perform, this is my motherland, Chaka Chaka vows" data-wp-pid="63647" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-350x250.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-750x536.jpg 750w" data-expand="700" /></div></a> <div class="jeg_post_category"> <span><a href="https://nilepost.co.ug/category/lifestyle/entertainment/" class="category-entertainment">Entertainment</a></span> </div> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/">It is not true that I had a wrong Visa to Uganda- Chaka Chaka (Video)</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/crispus/">Crispus Mugisha</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/"><i class="fa fa-clock-o"></i> March 12, 2020</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div> <div class="jeg_post_excerpt"> <p>South African singer Mhinga Ntobezedwa Machaka Yvonne commonly known as Chaka Chaka has refuted claims by Ugandan authorities that her...</p> <a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/" class="jeg_readmore">Read more</a> </div> </div> </article> <div class="jeg_posts_wrap"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_sm post-69613 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-security tag-bugiri-imam tag-general-court-martial tag-ldu tag-lt-gen-andrew-gutti tag-sheikh-masudi-mutumba tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/"> <div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Gun used to kill Bugiri Imam had earlier been robbed from a security guard" data-wp-pid="67778" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/02/sus-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/02/sus-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/02/sus-350x250.jpg 350w" data-expand="700" /></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/">Security guard pleads guilty to shooting dead Bugiri Imam before army court</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69608 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-politics tag-isma-luzige tag-museveni tag-nrm tag-nrm-southern-africa-chapter tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/2021-elections-nrm-in-southern-africa-to-send-400-man-team-to-campaign-for-museveni/"> <div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="2021 elections: NRM in Southern Africa to send 400 man team to campaign for Museveni" data-wp-pid="69611" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/25247e96-3443-45f7-bf86-10ff5cb13f8e-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/25247e96-3443-45f7-bf86-10ff5cb13f8e-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/03/25247e96-3443-45f7-bf86-10ff5cb13f8e-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/03/25247e96-3443-45f7-bf86-10ff5cb13f8e-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2020/03/25247e96-3443-45f7-bf86-10ff5cb13f8e-1140x815.jpg 1140w" data-expand="700" /></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/2021-elections-nrm-in-southern-africa-to-send-400-man-team-to-campaign-for-museveni/">2021 elections: NRM in Southern Africa to send 400 man team to campaign for Museveni</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/2021-elections-nrm-in-southern-africa-to-send-400-man-team-to-campaign-for-museveni/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69599 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-kcca tag-patrick-onyango tag-rebecca-kadaga tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/11/kadaga-slams-police-on-misuse-of-guns-orders-them-to-foot-bills-for-student-shot-in-mouth/"> <div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="WHO warns Coronavirus is &#8216;high risk,&#8217; stops short of declaring emergency" data-wp-pid="65500" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/01/Speaker-Rebecca-Kadaga-gestures-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/01/Speaker-Rebecca-Kadaga-gestures-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/01/Speaker-Rebecca-Kadaga-gestures-350x250.jpg 350w" data-expand="700" /></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/11/kadaga-slams-police-on-misuse-of-guns-orders-them-to-foot-bills-for-student-shot-in-mouth/">Kadaga slams Police on misuse of guns, orders them to foot bills for student shot in mouth</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/11/kadaga-slams-police-on-misuse-of-guns-orders-them-to-foot-bills-for-student-shot-in-mouth/" ><i class="fa fa-clock-o"></i> March 11, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69576 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-politics tag-electoral-commission tag-justice-simon-byabakama tag-lt-gen-henry-tumukunde tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/11/tough-conditions-as-tumukunde-is-cleared-to-consult-voters-on-presidential-bid/"> <div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="If I was Rwanda, I would support anyone who wants to cause change in Uganda- Gen. Tumukunde" data-wp-pid="69121" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/tumukunde-1-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/tumukunde-1-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/03/tumukunde-1-350x250.jpg 350w" data-expand="700" /></div> </a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/11/tough-conditions-as-tumukunde-is-cleared-to-consult-voters-on-presidential-bid/">Tough conditions as Tumukunde is cleared to consult voters on presidential bid</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/11/tough-conditions-as-tumukunde-is-cleared-to-consult-voters-on-presidential-bid/" ><i class="fa fa-clock-o"></i> March 11, 2020</a></div></div> </div> </article> </div> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_69626_0_5e6a0a9d85915 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":69626,"include_category":"","exclude_category":"","include_author":"","include_tag":"68160,3029,1887,4187,124,1712,21019","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":20,"excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"5","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_2"};</script> </div></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"><div id="comments" class="comment-wrapper section" data-type="facebook" data-id="1950641841925118"><h3 class='comment-heading'>Discussion about this post</h3><div class="fb-comments" data-href="https://nilepost.co.ug/2020/03/12/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules/" data-num-posts="10" data-width="100%"></div></div></div> </div> </div> <div class="jeg_sidebar left jeg_sticky_sidebar col-md-3"> <div class="widget widget_jnews_social_counter" id="jnews_social_counter-8"><div class="jeg_block_heading jeg_block_heading_6 jnews_5e6a0a9d91152"><h3 class="jeg_block_title"><span>Follow Us</span></h3></div><ul class="jeg_socialcounter col1 light"> <li class="jeg_facebook"> <a href="https://www.facebook.com/nilepostnews" ><i class="fa fa-facebook"></i> <span>151.2k</span> <small>Fans</small> </a> </li><li class="jeg_twitter"> <a href="https://twitter.com/nilepostnews" ><i class="fa fa-twitter"></i> <span>81.8k</span> <small>Followers</small> </a> </li> </ul></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-16"><div class='jeg_ad jeg_ad_module jnews_module_69626_1_5e6a0a9d91840 '><div class='ads-wrapper'><a href='https://www.ura.go.ug/' target='_blank' class='adlink ads_image '><img src='https://nilepost.co.ug/wp-content/uploads/2019/09/WhatsApp-Image-2019-09-11-at-4.29.13-PM.jpeg' alt='URA' data-pin-no-hover="true"></a><a href='https://www.ura.go.ug/' target='_blank' class='adlink ads_image_tablet '><img src='https://nilepost.co.ug/wp-content/uploads/2019/09/WhatsApp-Image-2019-09-11-at-4.29.13-PM.jpeg' alt='URA' data-pin-no-hover="true"></a><a href='https://www.ura.go.ug/' target='_blank' class='adlink ads_image_phone '><img src='https://nilepost.co.ug/wp-content/uploads/2019/09/WhatsApp-Image-2019-09-11-at-4.29.13-PM.jpeg' alt='URA' data-pin-no-hover="true"></a></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-20"><div class='jeg_ad jeg_ad_module jnews_module_69626_2_5e6a0a9d91b18 '><div class='ads-wrapper'></div></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-5"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_69626_3_5e6a0a9d91f36 jeg_pb_boxed normal " data-unique="jnews_module_69626_3_5e6a0a9d91f36"> <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Latest</span></h3> </div> <div class="jeg_block_container"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_sm post-69646 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-cosase tag-us-government"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/us-government-urges-uganda-to-punish-those-implicated-in-the-cosase-bou-probe/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="67" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="BoU officials took over banks without ascertaining assets, liabilities" data-wp-pid="29274" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase.jpg 900w, https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase-300x169.jpg 300w, https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase-768x432.jpg 768w, https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase-800x450.jpg 800w, https://nilepost.co.ug/wp-content/uploads/2018/11/Cosase-600x337.jpg 600w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/us-government-urges-uganda-to-punish-those-implicated-in-the-cosase-bou-probe/">US government urges Uganda to punish those implicated in the COSASE BoU probe</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/us-government-urges-uganda-to-punish-those-implicated-in-the-cosase-bou-probe/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69645 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-arrest-police-officer tag-mining-investor tag-nakalema tag-ugandanews"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/nakalema-orders-arrest-of-cid-police-officer-for-frustrating-investor/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Nakalema orders arrest of CID police officer for frustrating investor" data-wp-pid="69647" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/KISITA-mining-company-Meeting-with-Police-Minerals-9-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/KISITA-mining-company-Meeting-with-Police-Minerals-9-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/03/KISITA-mining-company-Meeting-with-Police-Minerals-9-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/03/KISITA-mining-company-Meeting-with-Police-Minerals-9-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2020/03/KISITA-mining-company-Meeting-with-Police-Minerals-9-1140x815.jpg 1140w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/nakalema-orders-arrest-of-cid-police-officer-for-frustrating-investor/">Nakalema orders arrest of CID police officer for frustrating investor</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/nakalema-orders-arrest-of-cid-police-officer-for-frustrating-investor/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69640 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-lifestyle tag-deported tag-uganda tag-ugandanews tag-visa tag-yvonne-chaka-chaka"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="I am coming back to Uganda to perform, this is my motherland, Chaka Chaka vows" data-wp-pid="63647" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/01/chaka-750x536.jpg 750w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/">It is not true that I had a wrong Visa to Uganda- Chaka Chaka (Video)</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/it-is-not-true-that-i-had-a-wrong-visa-to-uganda-chaka-chaka-video/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69639 post type-post status-publish format-standard has-post-thumbnail hentry category-africa category-news tag-coronavirus tag-ivory-coast"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/ivory-coast-confirms-first-coronavirus-case/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Ivory Coast confirms first coronavirus case" data-wp-pid="69641" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/Coronavirus-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/Coronavirus-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/03/Coronavirus-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/03/Coronavirus-750x536.jpg 750w, https://nilepost.co.ug/wp-content/uploads/2020/03/Coronavirus-1140x815.jpg 1140w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/ivory-coast-confirms-first-coronavirus-case/">Ivory Coast confirms first coronavirus case</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/ivory-coast-confirms-first-coronavirus-case/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69636 post type-post status-publish format-standard has-post-thumbnail hentry category-2021-elections-watch category-featured category-news tag-bobi-wine tag-funding tag-government tag-ugandanews"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Barbie Kyagulanyi: Behind Bobi Wine’s success, is Bobi himself (VIDEO)" data-wp-pid="68842" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-350x250.jpg 350w, https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-750x536.jpg 750w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/">I am being funded by people in Museveni’s government, they are not willing to go public yet &#8211; Bobi Wine (Video)</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_69626_3_5e6a0a9d91f36 = {"header_icon":"","first_title":"Latest","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"","post_type":"post","content_type":"all","number_post":"5","post_offset":"","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"1","pagination_scroll_limit":"","boxed":"1","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script> </div></div></div><div class="jeg_sidebar right jeg_sticky_sidebar col-md-3"> <div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-10"><div class='jeg_ad jeg_ad_module jnews_module_69626_4_5e6a0a9d955b2 '><div class='ads-wrapper'><a href="https://bit.ly/4GPocketMiFiNP" target='_blank' class='adlink ads_image '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='Airtel Internet' data-pin-no-hover="true"></a><a href="https://bit.ly/4GPocketMiFiNP" target='_blank' class='adlink ads_image_tablet '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='Airtel Internet' data-pin-no-hover="true"></a><a href="https://bit.ly/4GPocketMiFiNP" target='_blank' class='adlink ads_image_phone '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='Airtel Internet' data-pin-no-hover="true"></a></div></div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-13"><div class='jeg_ad jeg_ad_module jnews_module_69626_5_5e6a0a9d95858 '><div class='ads-wrapper'><a href='https://www.airtel.co.ug/' target='_self' class='adlink ads_image '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='' data-pin-no-hover="true"></a><a href='https://www.airtel.co.ug/' target='_self' class='adlink ads_image_tablet '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='' data-pin-no-hover="true"></a><a href='https://www.airtel.co.ug/' target='_self' class='adlink ads_image_phone '><img src='https://nilepost.co.ug/wp-content/uploads/2020/03/250-250PX.gif' alt='' data-pin-no-hover="true"></a></div></div></div><div class="widget widget_jnews_module_block_17" id="jnews_module_block_17-1"><div class="jeg_postblock_17 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_69626_6_5e6a0a9d95d6f jeg_pb_boxed normal " data-unique="jnews_module_69626_6_5e6a0a9d95d6f"> <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right"> <h3 class="jeg_block_title"><span>Featured</span></h3> </div> <div class="jeg_block_container"> <div class="jeg_posts_wrap"> <div class="jeg_posts jeg_load_more_flag"> <article class="jeg_post jeg_pl_md_1 post-69636 post type-post status-publish format-standard has-post-thumbnail hentry category-2021-elections-watch category-featured category-news tag-bobi-wine tag-funding tag-government tag-ugandanews"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/"><div class="thumbnail-container animate-lazy size-500 "><img width="360" height="180" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Barbie Kyagulanyi: Behind Bobi Wine’s success, is Bobi himself (VIDEO)" data-wp-pid="68842" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-360x180.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-360x180.jpg 360w, https://nilepost.co.ug/wp-content/uploads/2020/03/Bobi-Wine-Robert-Kyagulanyi-8-750x375.jpg 750w" data-expand="700" /></div></a> <div class="jeg_post_category"> <span><a href="https://nilepost.co.ug/category/news/2021-elections-watch/" class="category-2021-elections-watch">2021 Elections Watch</a></span> </div> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/">I am being funded by people in Museveni’s government, they are not willing to go public yet &#8211; Bobi Wine (Video)</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_author"><span class="by">by</span> <a href="https://nilepost.co.ug/author/crispus/">Crispus Mugisha</a></div><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/"><i class="fa fa-clock-o"></i> March 12, 2020</a></div><div class="jeg_meta_comment"><a href="https://nilepost.co.ug/2020/03/12/i-am-being-funded-by-people-in-musevenis-government-they-are-not-willing-to-go-public-yet-bobi-wine-video/#comments" ><i class="fa fa-comment-o"></i> 0 </a></div></div> <div class="jeg_post_excerpt"> <p>People Power leader and Kyadondo East Legislator Robert...</p> </div> </div> </article> <article class="jeg_post jeg_pl_sm post-69617 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news tag-coronavirus tag-mps tag-taxpayers"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/mps-warn-government-not-to-defraud-taxpayers-over-ugandan-students-in-china/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Works, security take lion’s share in Shs40.5 trillion budget" data-wp-pid="45102" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2019/05/Hon-BahatiL-interacts-with-Hon-Lugoolobi-and-Ssekikubo-after-House-passed-the-2019-and-20-Budget-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2019/05/Hon-BahatiL-interacts-with-Hon-Lugoolobi-and-Ssekikubo-after-House-passed-the-2019-and-20-Budget-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2019/05/Hon-BahatiL-interacts-with-Hon-Lugoolobi-and-Ssekikubo-after-House-passed-the-2019-and-20-Budget-350x250.jpg 350w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/mps-warn-government-not-to-defraud-taxpayers-over-ugandan-students-in-china/">MPs warn government not to defraud taxpayers over Ugandan students in China</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/mps-warn-government-not-to-defraud-taxpayers-over-ugandan-students-in-china/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article><article class="jeg_post jeg_pl_sm post-69613 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-security tag-bugiri-imam tag-general-court-martial tag-ldu tag-lt-gen-andrew-gutti tag-sheikh-masudi-mutumba tag-uganda tag-ugandan-news"> <div class="jeg_thumb"> <a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/"><div class="thumbnail-container animate-lazy size-715 "><img width="120" height="86" src="https://nilepost.co.ug/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Gun used to kill Bugiri Imam had earlier been robbed from a security guard" data-wp-pid="67778" nopin="nopin" data-src="https://nilepost.co.ug/wp-content/uploads/2020/02/sus-120x86.jpg" data-sizes="auto" data-srcset="https://nilepost.co.ug/wp-content/uploads/2020/02/sus-120x86.jpg 120w, https://nilepost.co.ug/wp-content/uploads/2020/02/sus-350x250.jpg 350w" data-expand="700" /></div></a> </div> <div class="jeg_postblock_content"> <h3 class="jeg_post_title"> <a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/">Security guard pleads guilty to shooting dead Bugiri Imam before army court</a> </h3> <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://nilepost.co.ug/2020/03/12/security-guard-pleads-guilty-to-shooting-dead-bugiri-imam-before-army-court/" ><i class="fa fa-clock-o"></i> March 12, 2020</a></div></div> </div> </article> </div> </div> <div class='module-overlay'> <div class='preloader_type preloader_circle'> <div class="module-preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="module-preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="module-preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div> </div> </div> <div class="jeg_block_navigation"> <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div> </div> <script>var jnews_module_69626_6_5e6a0a9d95d6f = {"header_icon":"","first_title":"Featured","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"95","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"8","excerpt_ellipsis":"...","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"1","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_17"};</script> </div></div></div> </div> <div class="jeg_ad jeg_article jnews_article_bottom_ads"> <div class='ads-wrapper '></div> </div> </div></div> </div> </div> <div id="post-body-class" class="post-template-default single single-post postid-69626 single-format-standard wp-megamenu jeg_single_tpl_1 jnews jeg_boxed jnews_boxed_container jnews_boxed_container_shadow jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div> </div> <div class="post-ajax-overlay"> <div class="preloader_type preloader_circle"> <div class="newsfeed_preloader jeg_preloader dot"> <span></span><span></span><span></span> </div> <div class="newsfeed_preloader jeg_preloader circle"> <div class="jnews_preloader_circle_outer"> <div class="jnews_preloader_circle_inner"></div> </div> </div> <div class="newsfeed_preloader jeg_preloader square"> <div class="jeg_square"><div class="jeg_square_inner"></div></div> </div> </div></div> </div> <div class="footer-holder" id="footer" data-id="footer"> <div class="jeg_footer jeg_footer_4 normal"> <div class="jeg_footer_container jeg_container"> <div class="jeg_footer_content"> <div class="container"> <div class="row"> <div class="jeg_footer_primary clearfix"> <div class="col-md-9 footer_column"> <ul class="jeg_menu_footer"><li id="menu-item-33411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33411"><a href="#">About</a></li><li id="menu-item-33412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33412"><a href="#">Advertise</a></li><li id="menu-item-33413" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33413"><a href="#">Careers</a></li></ul> </div> <div class="col-md-3 footer_column footer_right"> <div class="footer-text"> <strong> Call us: +256-417-720-101 </div> </div> </div> <div class="jeg_footer_secondary clearfix"> <div class="col-md-9 footer_column"> <p class="copyright"> © 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company. </p> </div> <div class="col-md-3 footer_column footer_right"> <div class="jeg_social_icon_block socials_widget nobg"> <a href="https://www.facebook.com/nilepostnews" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a> </div> </div> </div> </div> </div> </div> </div></div> </div> <div class="jscroll-to-top"> <a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a> </div> </div> <div id="jeg_off_canvas" class="normal"> <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a> <div class="jeg_bg_overlay"></div> <div class="jeg_mobile_wrapper"> <div class="nav_wrap"> <div class="item_main"> <div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round"> <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a> <form action="https://nilepost.co.ug/" method="get" class="jeg_search_form" target="_top"> <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off"> <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"> <div class="search-result-wrapper"> </div> <div class="search-link search-noresult"> No Result </div> <div class="search-link search-all-button"> <i class="fa fa-search"></i> View All Result </div></div></div><div class="jeg_aside_item"> <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-765"><a href="https://nilepost.co.ug/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14258"><a href="https://nilepost.co.ug/category/news/education/">Education</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33490"><a href="https://nilepost.co.ug/category/news/exclusive/">Exclusive</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33491"><a href="https://nilepost.co.ug/category/news/investigations/">Investigations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33492"><a href="https://nilepost.co.ug/category/news/security/">Security</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33668"><a href="https://nilepost.co.ug/category/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-768"><a href="https://nilepost.co.ug/category/opinions/">Opinions</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34124"><a href="https://nilepost.co.ug/category/opinions/columns/">Columns</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34125"><a href="https://nilepost.co.ug/category/opinions/columns/two-sides-of-a-coin/">Two Sides of a Coin</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34126"><a href="https://nilepost.co.ug/category/opinions/columns/unconventional-thought/">Unconventional Thought</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53331"><a href="https://nilepost.co.ug/category/opinions/columns/bazanyes-quick-shots/">Bazanye&#8217;s Quick Shots</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55490"><a href="https://nilepost.co.ug/category/opinions/columns/this-week-in-ugandan-news/">This Week in Ugandan News</a></li></ul></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-14629"><a href="https://nilepost.co.ug/category/global-watch/">Global</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14628"><a href="https://nilepost.co.ug/category/global-watch/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33864"><a href="https://nilepost.co.ug/category/global-watch/asia/">Asia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33866"><a href="https://nilepost.co.ug/category/global-watch/middle-east/">Middle East</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33865"><a href="https://nilepost.co.ug/category/global-watch/europe/">Europe</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33867"><a href="https://nilepost.co.ug/category/global-watch/the-americas/">The Americas</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-796"><a href="https://nilepost.co.ug/category/east-africa/">East Africa</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-798"><a href="https://nilepost.co.ug/category/east-africa/kenya/">Kenya</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-800"><a href="https://nilepost.co.ug/category/east-africa/rwanda/">Rwanda</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-799"><a href="https://nilepost.co.ug/category/east-africa/south-sudan/">South Sudan</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33497"><a href="#">Lifestyle</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55232"><a href="https://nilepost.co.ug/category/lifestyle/entertainment/">Entertainment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33498"><a href="https://nilepost.co.ug/category/lifestyle/health-2/">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33500"><a href="https://nilepost.co.ug/category/lifestyle/tour-travel/">Tour &#038; Travel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33499"><a href="https://nilepost.co.ug/category/lifestyle/love-therapist/">Love Therapist</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33868"><a href="https://nilepost.co.ug/category/lifestyle/homes/">Homes</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3344"><a href="https://nilepost.co.ug/category/technology/">Tech</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3727"><a href="#">Special Reports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33486"><a href="https://nilepost.co.ug/category/special-reports/kabaka-mutebis-25th-coronation-series/">Kabaka Mutebi&#8217;s 25th Coronation Series</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33485"><a href="https://nilepost.co.ug/category/special-reports/focus-on-somalia/">Focus on Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33487"><a href="https://nilepost.co.ug/category/special-reports/sino-africa/">Sino-Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33489"><a href="https://nilepost.co.ug/category/special-reports/uganda56/">Uganda at 56</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33501"><a href="https://nilepost.co.ug/category/special-reports/anti-corruption-fight/">Anti-Corruption Fight</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2706"><a href="https://nilepost.co.ug/age-limit-country-map/">Age Limit Map</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33488"><a href="https://nilepost.co.ug/category/special-reports/tuve-ku-kaveera/">Tuve Ku Kaveera</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-17600"><a href="https://nilepost.co.ug/category/sports/">Sports</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14633"><a href="https://nilepost.co.ug/category/sports/place-it/">Place-It</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33495"><a href="https://nilepost.co.ug/category/sports/startimes-uganda-premier-league/">StarTimes Uganda Premier League</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14632"><a href="https://nilepost.co.ug/category/sports/bundesliga/">Bundesliga</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33496"><a href="https://nilepost.co.ug/category/sports/world-cup/">World Cup</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33507"><a href="https://nilepost.co.ug/category/live/">Live</a></li></ul></div> </div> <div class="item_bottom"> <div class="jeg_aside_item socials_widget nobg"> <a href="https://www.facebook.com/nilepostnews" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nilepostnews" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://nilepost.co.ug/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© 2020 <a href="http://nextmedia.co.ug" title="Next Media Services Ltd">Nile Post Uganda Ltd.</a> - A Next Media Services Company.</p></div> </div></div> </div></div><script type="text/javascript">var jfla = ["view_counter"]</script><div class="jeg_read_progress_wrapper"></div><noscript id="deferred-styles"><link rel='stylesheet' id='jeg_customizer_font-css' href='//fonts.googleapis.com/css?family=Roboto%3Areguler%7CRoboto+Condensed%3A700%2Cregular%2Cregular%2C700%7CPT+Serif%3Aregular%2Citalic%2C700%2C700italic&#038;ver=1.0.0' type='text/css' media='all' /><!--[if lt IE 9]><link rel='stylesheet' id='vc_lte_ie9-css' href='https://nilepost.co.ug/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' /><![endif]--><link rel='stylesheet' id='poppins-css' href='//fonts.googleapis.com/css?family=Poppins%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2Cregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;ver=1.3.2' type='text/css' media='all' /><link rel='stylesheet' id='minit-css-css' href='https://nilepost.co.ug/wp-content/uploads/minit/9f8688ff.css' type='text/css' media='all' /></noscript><script>var loadDeferredStyles = function() {var addStylesNode = document.getElementById("deferred-styles");var replacement = document.createElement("div");replacement.innerHTML = addStylesNode.textContent;document.body.appendChild(replacement)
addStylesNode.parentElement.removeChild(addStylesNode);};var raf = requestAnimationFrame || mozRequestAnimationFrame ||
webkitRequestAnimationFrame || msRequestAnimationFrame;if (raf) raf(function() { window.setTimeout(loadDeferredStyles, 0); });else window.addEventListener('load', loadDeferredStyles);</script><style id='minit-css-inline-css' type='text/css'>#rs-demo-id{}</style><!--[if lt IE 9]><script type='text/javascript' src='https://nilepost.co.ug/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=5.1.0'></script><![endif]--><script type='text/javascript'>
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/nilepost.co.ug","hash_tracking":"false"};var fvpdata = {"ajaxurl":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","nonce":"c5700d1420","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};var wpmm_object = {"ajax_url":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php","wpmm_responsive_breakpoint":"767px","wpmm_disable_mobile":"false"};var postgrid_ajax_load = {"ajax_url":"https:\/\/nilepost.co.ug\/wp-admin\/admin-ajax.php"};var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"69626","isblog":"1","admin_bar":"0","follow_video":"1","follow_position":"top_right","rtl":"0","gif":"","site_slug":"\/","site_domain":"nilepost.co.ug"};
</script><script async type='text/javascript' src='https://nilepost.co.ug/wp-content/uploads/minit/b0af39fa.js'></script><script id="minit-async-scripts" type="text/javascript">(function() {var js, fjs = document.getElementById('minit-async-scripts'),add = function( url, id ) {js = document.createElement('script');js.type = 'text/javascript';js.src = url;js.async = true;js.id = id;fjs.parentNode.insertBefore(js, fjs);};add( "", "async-script-jquery" ); })();</script><div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/nilepost.co.ug\/2020\/03\/12\/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules\/"},"dateCreated":"2020-03-12 07:23:41","datePublished":"2020-03-12 07:23:41","dateModified":"2020-03-12 07:25:12","url":"https:\/\/nilepost.co.ug\/2020\/03\/12\/judiciary-is-not-a-mere-department-under-justice-ministry-but-autonomous-court-rules\/","headline":"Judiciary is not a mere department under justice ministry but  autonomous &#8211; court rules","name":"Judiciary is not a mere department under justice ministry but  autonomous &#8211; court rules","articleBody":"<strong>The Constitutional Court has ruled that the judiciary should be independent and should have its own self-accounting status just like the two other arms of government.<\/strong>\r\n\r\nIn 2018, lawyers under their professional body, the Uganda Law Society (ULS), have sued government for failure to provide an enabling environment to the Judiciary to have its own self-accounting status like other two arms of government.\r\n\r\nThe lawyers argued that the independence of the judiciary is provided for under Article 128 (1) of the Constitution demands that in exercise of their judicial power, courts shall not be subject to the control of any person or authority.\r\n\r\nOn Wednesday, a panel of five justices including Kenneth Kakuru, Geoffrey Kiryabwire, Cheborion Barishaki, Ezekiel Muhanguzi and Stephen Musota ruled that it was a contravention of the Constitution for government not to implement the autonomous status of the judiciary.\r\n\r\n\u201cThe failure by the executive and parliament to take steps in a reasonable time to enact a law to implement the judiciary\u2019s autonomy contravenes articles 8A and National Objective and Directive Principles of State Policy VIII and Article 128(3) of the 1995 Constitution,\u201d said Justice Barishaki who wrote the lead judgment.\r\n\r\nQuoting the Public Finance Management Act, 2015, Uganda Law Society told court in its petition that it is wrong for the Secretary to the Treasury to have powers to the effect that he issues directives to all accounting officers but includes the self-accounting institutions like the judiciary in the same category.\r\n\r\nIn their judgment, the justices of the Constitutional court reasoned with the lawyers\u2019 body saying the practice is illegal since it undermines the judiciary\u2019s independence.\r\n\r\nIn the petition, the lawyers\u2019 body told court that it is unconstitutional for the Justice Minister to annually approve the budgetary framework of the judiciary yet it is an independent arm of government.\r\n\r\nThe court reasoned with the petitioners saying it is wrong for government to take the judiciary as a mere department under the Ministry of Justice during the budgetary process.\r\n\r\n\u201cThe judiciary as an arm of government is supposed to take control of its budgetary processes without any interference from the executive. The executive\u2019s role is to forward the judiciary\u2019s budgetary estimates to parliament for consideration,\u201d the judges ruled.\r\n\r\nThe court also ruled that the role of Permanent Secretary ought not to have extended to the judiciary since the Chief Justice is the accounting officer of the third arm of government.\r\n\r\nThe judges said that the Permanent Secretary ought to report to the Chief Justice and not to the executive arm of government as is the case currently.\r\n\r\n\u201cThe allocation of inadequate resources to the judiciary is inconsistent with and in contravention of the Constitution,\u201d the Constitutional Court ruled.\r\n\r\n&nbsp;\r\n\r\n&nbsp;\r\n\r\n&nbsp;","author":{"@type":"Person","name":"Kenneth Kazibwe","url":"https:\/\/nilepost.co.ug\/author\/kenny\/","sameAs":["http:\/\/nilepost.co.ug"]},"articleSection":["News"],"image":{"@type":"ImageObject","url":"https:\/\/nilepost.co.ug\/wp-content\/uploads\/2018\/07\/Judges.jpg","width":620,"height":340},"publisher":{"@type":"Organization","name":"","url":"https:\/\/nilepost.co.ug","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/nilepostnews","https:\/\/twitter.com\/nilepostnews","http:\/\/nilepost.co.ug\/feed"]}}</script><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Judiciary is not a mere department under justice ministry but  autonomous &#8211; court rules","published":"2020-03-12 07:23:41","updated":"2020-03-12 07:25:12"}</script><script type='text/javascript'>function initTwitCount(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs)}}var ssb_twit_count_init=!1;addEventListener('mouseover',function(event){if(!ssb_twit_count_init){initTwitCount(document,'script','twitcount_plugins')
ssb_twit_count_init=!0}})</script><style type="text/css" id="wp-custom-css">.nivo-caption{background:transparent !important;position:absolute;color:transparent !important;-moz-opacity:.8}</style></body></html><!-- WP Fastest Cache file was created in 0.97243213653564 seconds, on 12-03-20 10:10:37 --><!-- via php -->